Click here to load reader

EXAMENUL DE BACALAUREAT – 2008 la …...EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

  • View
    7

  • Download
    1

Embed Size (px)

Text of EXAMENUL DE BACALAUREAT – 2008 la …...EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la...

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect. 1. Variabila x este de tip real. Care dintre următoarele expresii C/C++ are valoarea 1 dacă şi

    numai dacă numărul real memorat în variabila x aparţine intervalului (5,8]? (4p.)

    a. (x=5) b. (x5)

    c. (x>8) || (x0 execută │ c n%10 │ n [n/10] │┌dacă c%3=0 atunci ││ z z+p*(9-c) ││ p p*10 │└■ └■ scrie z

    d) Scrieţi programul C/C++ corespunzător algoritmului dat. (10p.)

    1

    www.bacalaureat2008.info Tot ce trebuie sa stii despre Examenul de Bacalaureat 2008

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect. 1. Variabilele x şi y sunt tip int. Care dintre expresiile C/C++ de mai jos are valoarea 1

    dacă şi numai dacă valorile întregi nenule memorate în variabilele x şi y sunt egale? (4p.)

    a. (x%y==0) && (y%x==0) && (x*y>0) b. (x

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect. 1. Care dintre următoarele expresii C/C++ are valoarea 1 dacă şi numai dacă numărul real

    memorat în variabila x se află în intervalul (-2,2)? (4p.)

    a. x*x-40 c. (20 execută │ citeşte y (număr natural) │ ┌dacă z

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect. 1. Care este rezultatul evaluării expresiei C/C++ alăturate? (4p.) 10*2/3*3/2

    a. 0 b. 10 c. 1.11 d. 9 Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare. 2. Se consideră algoritmul alăturat, descris în pseudocod. S-a notat cu x%y restul împărţirii numărului întreg x la numărul întreg nenul y.

    a) Scrieţi ce se afişează pentru a=5 şi b=17. (6p.)

    b) Scrieţi toate perechile de valori care pot fi citite pentru variabilele a şi b, astfel încât să se afişeze, în acestă ordine, numerele: 0 2 4 6 8 10. (4p.)

    citeşte a,b (numere întregi) ┌dacă a

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect. 1. Variabila x este de tip real. Care dintre următoarele expresii C/C++ are valoarea 1 dacă şi

    numai dacă numărul real memorat în variabila x nu aparţine intervalului (2,9]? (4p.)

    a. (x>2) && (x0 şi y%10=z%10 execută │ y [y/10] │ z [z/10] └■ ┌dacă y+z=0 atunci │ scrie 1 │altfel │ scrie 0 └■

    c) Scrieţi în pseudocod un algoritm echivalent cu cel dat, în care să se folosească o singură structură repetitivă. (6p.)

    d) Scrieţi programul C/C++ corespunzător algoritmului dat. (10p.)

    5

    www.bacalaureat2008.info Tot ce trebuie sa stii despre Examenul de Bacalaureat 2008

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect. 1. Care dintre următoarele expresii C/C++, are ca valoare cel mai mic dintre numerele

    naturale nenule, cu cel mult 4 cifre fiecare, memorate în variabilele întregi x şi y? (4p.)

    a. (x+y-abs(x-y))/2 b. x+y-abs(x-y)/2

    c. (x+y+abs(x-y))/2 d. (x+y+abs(x+y))/2 Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare. 2. Se consideră algoritmul alăturat, descris în pseudocod: S-a notat cu [c] partea întreagă a numărului real c, iar cu a%b restul împărţirii numărului întreg a la numărul întreg nenul b.

    a) Scrieţi valoarea care se afişează, în urma executării algoritmului, dacă se citeşte numărul 9321. (6p.)

    b) Scrieţi o valoare care poate fi citită pentru n astfel încât să se afişeze valoarea 11. (4p.)

    c) Scrieţi în pseudocod un algoritm echivalent cu cel dat în care să se înlocuiască structura cât timp ... execută cu o structură repetitivă cu test final. (6p.)

    citeşte n (număr natural) s -1 ┌cât timp n>0 execută │┌dacă n%10>s atunci ││ s n%10 ││altfel ││ s 11 │└■ │ n [n/10] └■ scrie s

    d) Scrieţi programul C/C++ corespunzător algoritmului dat. (10p.)

    6

    www.bacalaureat2008.info Tot ce trebuie sa stii despre Examenul de Bacalaureat 2008

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect. 1. Variabilele x şi y sunt întregi. Care dintre expresiile C/C++ de mai jos are valoarea 1 dacă

    şi numai dacă numărul memorat în x este strict mai mare decât 0 şi numărul memorat în y este strict mai mare decât 5? (4p.)

    a. x*y-5!=0 b. x*(y-5)!=0

    c. x*(y-5)>=0 d. !(x*(y-5))

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect. 1. Care dintre următoarele expresii C/C++, are ca valoare cel mai mare dintre numerele

    naturale nenule memorate în variabilele întregi a şi b? (4p.)

    a. (a+b+abs(a-b))/2 b. a+b+abs(a-b)/2

    c. (a+b-abs(a-b))/2 d. (a+b-abs(a+b))/2 Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare. 2. Se consideră algoritmul alăturat descris în pseudocod: S-a notat cu [c] partea întreagă a numărului real c, iar cu a%b restul împărţirii numărului întreg a la numărul întreg b.

    a) Scrieţi valoarea care se afişează, în urma executării algoritmului, dacă se citeşte pentru n valoarea 932125 şi pentru k valoarea 3. (4p.)

    b) Scrieţi un set de date de intrare astfel încât, în urma executării algoritmului, să se afişeze valoarea 0. (6p.)

    c) Scrieţi în pseudocod un algoritm echivalent cu cel dat în care să se înlocuiască structura cât timp ... execută cu o structură repetitivă cu test final. (6p.)

    citeşte n,k (numere naturale nenule) nr 0 p 1 ┌cât timp n≠0 şi k≠0 execută │┌dacă n%2=0 atunci ││ nr nr+ n%10*p ││ p p*10 ││altfel ││ k k-1 │└■ │ n [n/10] └■ scrie nr

    d) Scrieţi programul C/C++ corespunzător algoritmului dat. (10p.)

    8

    www.bacalaureat2008.info Tot ce trebuie sa stii despre Examenul de Bacalaureat 2008

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect. 1. Care dintre expresiile C/C++ de mai jos este

    echivalentă cu expresia alăturată? (4p.)

    ((a>3) && (a3) || (a3) || (a0 execută │┌dacă n%10

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect. 1. Care este valoarea expresiei C/C++ alăturate? (4p.) 9/2*2-5

    a. 3 b. 4

    c. -3 d. -3.75 Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare. 2. Se consideră algoritmul alăturat, descris în pseudocod S-a notat cu [c] partea întreagă a numărului real c, iar cu a%b restul împărţirii numărului întreg a la numărul întreg nenul b.

    a) Scrieţi valoarea care se afişează, în urma executării algoritmului, dacă se citeşte pentru n valoarea 23456 şi pentru k valoarea 3. (4p.)

    b) Scrieţi două seturi distincte de date de intrare, astfel încât, pentru fiecare dintre ele, în urma executării algoritmului, să se afişeze valoarea 234. (6p.)

    c) Scrieţi în pseudocod un algoritm echivalent cu cel dat în care să se înlocuiască structura cât timp ... execută cu o structură repetitivă cu test final. (6p.)

    citeşte n,k (numere naturale nenule) nr 0 p 1 ┌cât timp n≠0 şi k≠0 execută │┌dacă n%2≠0 atunci ││ nr nr + n%10*p ││ p p*10 ││altfel ││ k k-1 │└■ │ n [n/10] └■ scrie nr

    d) Scrieţi programul C/C++ corespunzător algoritmului dat. (10p.)

    10

    www.bacalaureat2008.info Tot ce trebuie sa stii despre Examenul de Bacalaureat 2008

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte)

    Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect.

    1. Variabilele x şi y sunt de tip întreg, x memorând valoarea 8, iar y valoarea 6. Care dintre expresiile C/C++ de mai jos are valoarea 0? (4p.)

    a. 3*x-4*y==0 b. (x+y)/2 > x%y+1

    c. !(x/2+2==y) d. x-y+3!=0 Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare. 2. Se consideră algoritmul alăturat, descris în pseudocod.

    S-a notat cu x%y restul împărţirii numărului natural x la numărul natural nenul y şi cu [z] partea întreagă a numărului real z.

    a) Scrieţi valoarea care se va afişa dacă se citeşte pentru n valoarea 296385, iar pentru k valoarea 3. (6p.)

    b) Dacă se citeşte pentru k valoarea 4, scrieţi o valoare nenulă care poate fi citită pentru n astfel încât numărul afişat în urma executării algoritmului să fie 1. (4p.)

    citeşte n,k (numere naturale) p 1 ┌cât timp n>0 şi k>0 execută │ c n%10 │ ┌dacă c%2=1 atunci │ │ p p*c │ └■ │ n [n/10] │ k k-1 └■ scrie p

    c) Scrieţi programul C/C++ corespunzător algoritmului dat. (10p.)

    d) Scrieţi în pseudocod un algoritm echivalent cu algoritmul dat, în care să se înlocuiască structura repetitivă cât timp...execută, cu o structură repetitivă pentru...execută. (6p.)

    11

    www.bacalaureat2008.info Tot ce trebuie sa stii despre Examenul de Bacalaureat 2008

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect.

    1. Care dintre următoarele expresii C/C++ are valoarea 1 dacă şi numai dacă variabilele x şi y memorează două numere naturale pare consecutive? (4p.)

    a. (x-y==2) && (y-x==2) b. (x==2) && (y==4)

    c. x-y==2 d. ((x-y==2) || (y-x==2)) && (x%2==0) Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare. 2. Se consideră algoritmul alăturat, descris în pseudocod.

    S-a notat cu [c] partea întreagă a numărului real c.

    a) Scrieţi valoarea care va fi afişată dacă se citesc, în această ordine, numerele 12, 7, 354, 9, 630, 0.

    (6p.)

    b) Scrieţi un şir de numere ce pot fi citite astfel încât valoarea afişată să fie 321. (4p.)

    citeşte x (număr natural) y 0 ┌cât timp x≠0 execută │ ┌cât timp x>9 execută │ │ x [x/10] │ └■ │ y y*10+x │ citeşte x └■ scrie y

    c) Scrieţi programul C/C++ corespunzător algoritmului dat. (10p.)

    d) Scrieţi în pseudocod un algoritm echivalent cu cel dat, în care să se înlocuiască fiecare dintre cele două structuri cât timp...execută, cu câte o structură repetitivă cu test final. (6p.)

    12

    www.bacalaureat2008.info Tot ce trebuie sa stii despre Examenul de Bacalaureat 2008

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect.

    1. Care dintre expresiile C/C++ de mai jos este echivalentă cu expresia alăturată? (4p.)

    !((a7))

    a. (a>=5)&&(b=5) && !(b0 execută │ │ ┌dacă n%2=1 atunci │ │ │ c c+1 │ │ └■ │ │ n [n/10] │ └■ │ ┌dacă c>0 atunci │ │ k k+1 │ └■ └■ scrie k

    13

    www.bacalaureat2008.info Tot ce trebuie sa stii despre Examenul de Bacalaureat 2008

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect. 1. Pentru care dintre perechile de valori

    de mai jos expresia C/C++ alăturată are valoarea 1? (4p.)

    (a%100==b%100) && (a>99) || (b>99)

    a. a=1003 şi b=3 b. a=35 şi b=35 c. a=1100 şi b=10 d. a=1234 şi b=12

    Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare. 2. Se consideră algoritmul alăturat, descris în pseudocod.

    S-a notat cu x%y restul împărţirii numărului natural x la numărul natural nenul y şi cu [z] partea întreagă a numărului real z.

    a) Scrieţi valoarea ce se va afişa dacă se citesc, în această ordine, numerele 12, 7, 354, 9, 1630, 0. (6p.)

    b) Scrieţi un set de date de intrare care să determine, în urma executării algoritmului, afişarea valorii 752. (4p.)

    c) Scrieţi programul C/C++ corespunzător algoritmului dat. (10p.)

    d) Scrieţi în pseudocod un algoritm echivalent cu cel dat, în care să se înlocuiască fiecare structură cât timp...execută, cu câte o structură repetitivă cu test final. (6p.)

    citeşte x (număr natural) n 0 ┌cât timp x≠0 execută │ y x; c 0 │ ┌cât timp y>0 execută │ │ ┌dacă y%10>c atunci │ │ │ c y%10 │ │ └■ │ │ y [y/10] │ └■ │ n n*10+c │ citeşte x └■ scrie n

    14

    www.bacalaureat2008.info Tot ce trebuie sa stii despre Examenul de Bacalaureat 2008

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect.

    1. Variabilele x şi y sunt de tip întreg, x memorând valoarea 4, iar y valoarea 2. Care dintre expresiile C/C++ de mai jos are valoarea 0? (4p.)

    a. x-y!=0 b. x+y>x%y+1 c. x-2*y==0 d. !(x==2*y) Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare. 2. Se consideră algoritmul alăturat, descris în pseudocod. S-a notat cu x%y restul împărţirii numărului natural x la numărul natural nenul y.

    a) Scrieţi valoarea care se afişează dacă pentru a se citeşte valoarea 25, iar pentru n se citeşte valoarea 6. (6p.)

    b) Scrieţi programul C/C++ corespunzător algoritmului dat. (10p.)

    citeşte a,n (numere naturale) ┌pentru i 1,n execută │ ┌dacă i%2=0 atunci │ │ a a-i*i │ │altfel │ │ a a+i*i │ └■ └■ scrie a

    c) Dacă pentru variabila a se citeşte valoarea 18, scrieţi valoarea care trebuie citită pentru variabila n, astfel încât să se afişeze numărul 8. (6p.)

    d) Dacă se citeşte pentru a valoarea 0, cu ce instrucţiune de atribuire trebuie înlocuită atribuirea a a-i*i în algoritmul dat, astfel încât algoritmul obţinut să afişeze valoarea expresiei n2 dacă numărul citit pentru n este impar şi respectiv 0 dacă numărul citit pentru n este par. (4p.)

    15

    www.bacalaureat2008.info Tot ce trebuie sa stii despre Examenul de Bacalaureat 2008

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect. 1. Care dintre următoarele instrucţiuni C/C++ determină inserarea cifrei 7 în faţa ultimei cifre a

    unui număr natural, cu mai mult de 2 cifre, memorat în variabila x? (4p.)

    a. x=(x/10*10+7)*10+x%10; b. x=x/10+7+x%10;

    c. x=(x%10*10+7)*10+x/10; d. x=(x/10+7)*10+x%10; Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare. 2. Se consideră algoritmul alăturat, descris în pseudocod. S-a notat cu cu x%y restul împărţirii numărului natural x la numărul natural, nenul, y.

    a) Scrieţi caracterele care se vor afişa în urma executării algoritmului dacă se citeşte valoarea 4. (6p.)

    b) Scrieţi o valoare care poate fi citită pentru variabila n, astfel încât caracterul * să fie afişat de exact 66 de ori. (4p.)

    c) Scrieţi programul C/C++ corespunzător algoritmului dat. (10p.)

    d) Scrieţi în pseudocod un algoritm echivalent cu cel dat, în care să se înlocuiască fiecare structură repetitivă pentru...execută cu câte o structură repetitivă cât timp...execută. (6p.)

    citeşte n (număr natural nenul) ┌pentru i 1,n-1 execută │┌dacă i%2=0 atunci ││ scrie ’#’ │└■ │┌pentru j i+1,n execută ││ scrie ’*’ │└■ └■

    16

    www.bacalaureat2008.info Tot ce trebuie sa stii despre Examenul de Bacalaureat 2008

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect.

    1. Care este valoarea pe care poate să o aibă iniţial variabila întreagă x dacă, la sfârşitul executării secvenţei alăturate, variabila întreagă y are valoarea 2? (4p.)

    y=0; do { x=x/10; y++; } while(x%100==0);

    a. 300 b. 5000 c. 120 d. 0 Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare. 2. Se consideră algoritmul alăturat, descris în pseudocod.

    a) Scrieţi succesiunea de caractere pe care le va afişa algoritmul dacă se citesc, în aceasta ordine, valorile 2, respectiv 9. (6p.)

    b) Scrieţi numărul de perechi de valori aparţinând intervalului [1,20], care pot fi citite pentru variabilele xşi y, astfel încât rezultatul afişat să fie format din exact 12 caractere ? (4p.)

    c) Scrieţi programul C/C++ corespunzător algoritmului dat. (10p.)

    d) Scrieţi în pseudocod un algoritm echivalent cu cel dat, în care să se înlocuiască structura repetitivă cât timp...execută cu o structură repetitivă de alt tip. (6p.)

    citeşte x,y (numere naturale) ┌dacă x

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect. 1. Care dintre următoarele instrucţiuni C/C++ determină eliminarea cifrei din mijloc a unui

    număr natural, cu exact 5 cifre, memorat în variabila x? (4p.)

    a. x=x/1000*100+x%100; b. x=x%1000*100+x/100;

    c. x=x/100*100+x%100; d. x=x/1000+x%100; Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare. 2. Se consideră algoritmul alăturat, descris în pseudocod. S-a notat cu a%b restul împărţirii numărului natural a la numărul natural, nenul, b şi cu a b interschimbarea valorilor reţinute de variabilele a şi b.

    a) Scrieţi succesiunea de caractere care se vor afişa în urma executării algoritmului dacă se citesc, în acestă ordine, valorile 2 şi 9. (6p.)

    b) Ştiind că pentru variabila y se citeşte valoarea 79, scrieţi 2 valori distincte care pot fi citite pentru variabila x, astfel încât să fie afişat de exact 40 de ori caracterul *. (4p.)

    c) Scrieţi programul C/C++ corespunzător algoritmului dat. (10p.)

    d) Scrieţi în pseudocod un algoritm echivalent cu cel dat, în care să se înlocuiască structura repetitivă câttimp...execută cu o structură repetitivă de alt tip. (6p.)

    citeşte x,y (numere naturale) ┌dacă x>y atunci │ y x └■ ┌dacă x%2=0 atunci │ x x+1 └■ ┌cât timp x≤y execută │ x x+2 │ scrie ‘*’ └■

    18

    www.bacalaureat2008.info Tot ce trebuie sa stii despre Examenul de Bacalaureat 2008

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect.

    1. Câte atribuiri se execută în secvenţa alăturată, dacă n şi p sunt variabile de tip întreg? (4p.)

    p=1; n=279; while (n>=100) { p=p*10; n=n-100; }

    a. 4 b. 6 c. 2 d. 8 Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare. 2. Se consideră algoritmul alăturat, descris în pseudocod. S-a notat cu cu x%y restul împărţirii numărului natural x la numărul natural nenul y şi cu [z] partea întreagă a numărului real z.

    a) Scrieţi numerele care se vor afişa în urma executării algoritmului dacă se citesc valorile a=312 şi b=1354. (6p.)

    b) Scrieţi câte o valoare care poate fi citită pentru variabila a, respectiv b, astfel încât algoritmul să afişeze exact 2 valori. (4p.)

    c) Scrieţi programul C/C++ corespunzător algoritmului dat. (10p.)

    d) Scrieţi în pseudocod un algoritm echivalent cu cel dat, în care să se înlocuiască structura pentru...execută cu o structură repetitivă de alt tip. (6p.)

    citeşte a,b (numere naturale) a a/10%10*10+a%10 b b/10%10*10+b%10 ┌pentru i a,b execută │┌dacă[i/10]=i%10 atunci ││ scrie i%10 │└■ └■

    19

    www.bacalaureat2008.info Tot ce trebuie sa stii despre Examenul de Bacalaureat 2008

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect.

    1. Care este valoarea tipărită de secvenţa de program C/C++ alăturată, ştiind că x şi y sunt variabile întregi, iar z este o variabilă reală? (4p.)

    x=30; y=5; z=(x+y)/6.0; z=(int)(z*100); z=z/100; coutb atunci ││ m m*10+b ││ a b │└■ └■ scrie m

    20

    www.bacalaureat2008.info Tot ce trebuie sa stii despre Examenul de Bacalaureat 2008

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect. 1. Care dintre expresiile C/C++ de mai jos are

    valoarea 1 după executarea secvenţei de instrucţiuni C/C++ alăturată, în care toate variabilele sunt întregi? (4p.)

    v1=0; v2=0; for(i=1;i

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect.

    1. Care este valoarea expresiei C/C++ alăturate dacă variabilele întregi a, b, c au valorile a=20, b=3, c=5? (4p.)

    (a/b%c

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect. 1. Variabilele a, b, c şi d memorează valori reale astfel încât a

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect.

    1. Care din următoarele afirmaţii despre operatorii din C/C++ este falsă? (4p.)

    a. > este operator relaţional b. % este operator aritmetic

    c. && este operator logic d.

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect. 1. În secvenţa pseudocod alăturată, toate variabilele

    memorează numere naturale. Cu ce valori pot fi înlocuite punctele de suspensie din secvenţă astfel încât, la finalul executării secvenţei să se afişeze, în acestă ordine, valorile 16 şi 41? (4p.)

    a ... b ... ┌pentru i 3,7 execută │ c a+b; x a; a b; b c └■ scrie x,c

    a. 1 şi 1 b. 3 şi 4 c. 5 şi 2 d. 2 şi 7 Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare. 2. Se consideră algoritmul alăturat descris în pseudocod. S-a notat cu y|x faptul că x este divizibil cu y.

    a) Scrieţi care sunt valorile ce se vor afişa pentru a=10, b=20 şi c=6. (6p.)

    b) Scrieţi un algoritm echivalent cu cel dat în care să se înlocuiască structura cât timp...execută cu o structură pentru...execută. (6p.)

    c) Scrieţi programul C/C++ corespunzător algoritmului dat. (10p.)

    d) Scrieţi o formulă care să calculeze câte numere se afişează dacă a≤b. (4p.)

    citeşte a,b,c (numere naturale nenule)┌dacă a>b atunci │ t a; a b; b t└■ ┌cât timp a≤b execută │ ┌dacă c|a atunci │ │ scrie a │ └■ │ a a+1 └■

    25

    www.bacalaureat2008.info Tot ce trebuie sa stii despre Examenul de Bacalaureat 2008

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect. 1. Care este cea mai mică valoare pe care o poate avea expresia C/C++

    alăturată dacă variabila x, de tip int, memorează un număr natural cu o singură cifră? (4p.)

    x/7-x%7

    a. 0 b. 1.14 c. -6 d. 1 Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare. 2. Se consideră algoritmul alăturat descris în pseudocod. S-a notat cu x%y restul împărţirii numărului natural x la numărul natural nenul y.

    a) Scrieţi valorile care se afişează pentru n=11. (6p.)

    b) Scrieţi programul C/C++ corespunzător algoritmului dat. (10p.)

    c) Scrieţi în pseudocod un algoritm echivalent cu cel dat, în care să se înlocuiască structura pentru...execută cu o structură repetitivă de un alt tip. (6p.)

    d) Scrieţi numărul de valori distincte, numere naturale nenule, cu cel mult două cifre fiecare, care pot fi citite pentru n, astfel încât cifra 1 să fie afişată de exact 3 ori. (4p.)

    citeste n (număr natural) c 0 ┌pentru i 1,n execută │ c (c+1)%10 │ scrie c └■

    26

    www.bacalaureat2008.info Tot ce trebuie sa stii despre Examenul de Bacalaureat 2008

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect.

    1. În expresia C/C++ alăturată variabila x este de tip întreg. Această expresie: (4p.)

    x%2+(x+1)%2

    a. are valoarea 1 pentru orice număr natural x. b. are valoarea 1 dacă şi numai dacă x este un număr par. c. are valoarea 1 dacă şi numai dacă x este un număr impar. d. are o valoare strict mai mare decât 1 pentru orice număr natural x.

    Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare. 2. Se consideră algoritmul alăturat descris în pseudocod. S-a notat cu x%y restul împărţirii numărului natural x la numărul natural nenul y şi cu [x] partea întreagă a numărului real x.

    a) Scrieţi valoarea care se afişează dacă se citesc numerele a=493 şi b=1836. (6p.)

    b) Scrieţi programul C/C++ corespunzător algoritmului dat. (10p.)

    c) Scrieţi în pseudocod un algoritm echivalent cu cel dat, în care să se înlocuiască structura cât timp...execută cu o structură repetitivă de un alt tip. (6p.)

    d) Scrieţi în pseudocod un algoritm echivalent cu cel dat, care să NU folosească structuri repetitive sau recursive. (4p.)

    citeste a,b (numere naturale) c 0 d 0 p 1 ┌cât timp a+b+c>0 execută│ c a%10+b%10+c │ d d+(c%10)*p │ p p*10 │ a [a/10] │ b [b/10] │ c [c/10] └■ scrie d

    27

    www.bacalaureat2008.info Tot ce trebuie sa stii despre Examenul de Bacalaureat 2008

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect. 1. Câte valori distincte, numere naturale, poate primi variabila x pentru ca valoarea expresiei

    x/2/2 scrisă în C/C++ să fie egală cu 1? (4p.) a. 1 b. 4 c. 2 d. 0

    Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare. 2. Se consideră algoritmul alăturat descris în pseudocod. S-a notat cu [x]partea întreagă a numărului real x.

    a) Scrieţi valoarea afişată dacă se citeşte numărul 120.12. (6p.)

    b) Scrieţi programul C/C++ corespunzător algoritmului dat. (10p.)

    c) Scrieţi în pseudocod un algoritm echivalent cu cel dat, în care să se înlocuiască structura cât timp...execută cu o structură repetitivă de un alt tip. (6p.)

    d) Scrieţi un număr real, cu exact două cifre la partea întreagă, care poate fi citit pentru x, astfel încât algoritmul să afişeze valoarea 1. (4p.)

    citeste x (număr real pozitiv) y [x] x x-y ┌cât timp x≠[x] execută│ x x*10 └■ ┌dacă x=y atunci │ scrie 1 │altfel │ scrie 2 └■

    28

    www.bacalaureat2008.info Tot ce trebuie sa stii despre Examenul de Bacalaureat 2008

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect. 1. Care dintre următoarele expresii C/C++ are valoarea 1 dacă şi numai dacă numărul natural

    nenul memorat în variabila x, de tip int, este divizibil cu 100? (4p.)

    a. x%10+x/10%10==0 b. x/100==0

    c. x%10+x/10==0 d. x%10+x%10/10==0 Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare. 2. Se consideră algoritmul alăturat descris în pseudocod. a) Scrieţi valoarea care se afişează dacă se citesc numerele n=6

    şi m=12. (6p.)

    b) Scrieţi programul C/C++ corespunzător algoritmului dat. (10p.)

    c) Scrieţi două perechi distincte de numere ce pot fi introduse pentru n şi m astfel încât să se afişeze valoarea 10, în urma executării algoritmului, pentru fiecare dintre perechi. (6

    d) Scrieţi în pseudocod un algoritm echivalent cu cel dat, care să NU folosească structuri repetitive sau recursive. (4p.)

    citeste n,m (numere naturale) ┌cât timp n≤m execută │ n n+1 │ m m-1 └■ ┌cât timp m

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect. 1. Care dintre următoarele expresii C/C++ are valoarea 1 dacă şi numai dacă numărul natural

    memorat de variabila x de tip int are exact două cifre? (4p.)

    a. x/100==0 b. x/100==0 && x%10==0

    c. x/10!=0 d. x/100==0 && x/10!=0 Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare. 2. Se consideră algoritmul alăturat descris în pseudocod. S-a notat cu x%y restul împărţirii numărului natural x la numărul natural nenul y şi cu [z] partea întreagă a numărului real z.

    a) Scrieţi valoarea care se afişează dacă se citeşte numărul n=5172. (6p.)

    b) Scrieţi programul C/C++ corespunzător algoritmului dat. (10p.)

    c) Scrieţi în pseudocod un algoritm echivalent cu cel dat, în care să se înlocuiască structura cât timp...execută cu o structură repetitivă de un alt tip. (6p.)

    d) Scrieţi două valori distincte, fiecare având exact patru cifre, care pot fi citite pentru variabila n astfel încât să se afişeze valoarea 2008 în ambele cazuri. (4p.)

    citeste n (număr natural) m 0 P 1 ┌cât timp n>0 execută │ c n%10 │ ┌dacă c>0 atunci │ │c c-1 │ └■ │ m m+c*p │ p p*10 │ n [n/10] └■ scrie m

    30

    www.bacalaureat2008.info Tot ce trebuie sa stii despre Examenul de Bacalaureat 2008

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect. 1. Se consideră variabila a care memorează un număr cu exact 6 cifre. Care dintre expresiile

    C/C++ de mai jos are ca valoare numărul format din cele două cifre din mijloc ale valorii memorate în a? (4p.)

    a. (a%100)/100 b. a/100%100

    c. a/1000+a%1000 d. a/100%10+a/1000%10 Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare. 2. Se consideră algoritmul alăturat, descris în pseudocod: S-a notat cu [x], partea întreagă a numărului real x.

    a) Scrieţi valorile care se vor afişa pentru a=9. (4p.)

    b) Scrieţi numărul valorilor din intervalul [1,5] care, citite pentru variabila a, determină, după executarea algoritmului alăturat, memorarea valorii 1 în variabila b. (6p.)

    c) Scrieţi programul C/C++ corespunzător algoritmului dat. (10p.)

    d) Scrieţi în pseudocod un algoritm echivalent cu cel dat, care să nu se utilizeze structuri repetitive sau subprograme recursive. (6p.)

    ┌citeşte a │ (număr natural, a>0) │ k 0 │ b [(a+1)*(a+2)/2] │┌cât timp b≥a execută ││ b b-a ││ k k+1 │└■ │ scrie b,k └■

    31

    www.bacalaureat2008.info Tot ce trebuie sa stii despre Examenul de Bacalaureat 2008

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect 1. Stabiliţi care dintre următoarele expresii C/C++ are valoarea 1 dacă şi numai dacă numărul

    întreg memorat în variabila x nu aparţine intervalului (-35,-20)∪ [17,100]. (4p.)

    a. (x100)

    b. (x=100)

    c. (x100)

    d. (x100) Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare. 2. Se consideră algoritmul alăturat, descris în pseudocod.

    a) Scrieţi numerele care sunt afişate dacă pentru a şi b se citesc valorile a=150 şi b=9. (4p.)

    b) Dacă pentru b se citeşte valoarea 150, scrieţi cea mai mare valoare care se poate citi pentru a, astfel încât algoritmul să afişeze exact 4 valori. (6p.)

    c) Scrieţi programul C/C++ corespunzător algoritmului dat. (10p.)

    d) Scrieţi în pseudocod un algoritm echivalent cu cel dat, în care să se înlocuiască structura cât timp … execută cu o structură repetitivă cu test final. (6p.)

    citeşte a,b (numere naturale) ┌dacă a>b atunci │ c b │ b a │ a c └■ ┌cât timp a

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect. 1. Variabila a memorează un număr natural care are exact 3 cifre. Care dintre expresiile

    C/C++ de mai jos are ca valoare numărul format din prima şi ultima cifră a numărului memorat de a? (4p.)

    a. a/10+a%100 b. a/100+a%10

    c. a/100*10+a%10 d. a-a/10%10 Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare. 2. Se consideră algoritmul alăturat descris in pseudocod.

    S-a notat cu [z], partea întreagă a numărului real z, iar cux%y restul împărţirii numărului natural x la numărul natural nenul y.

    a) Scrieţi care este valoarea afişată dacă pentru x şi y se citesc numerele x=5 şi y=27. (4p.)

    b) Scrieţi perechile de valori care pot fi citite pentru variabilele x şi y(x

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect.

    1. În secvenţa alăturată de program, instrucţiunea de afişare se va executa de un număr de ori egal cu: (4p.)

    for (i=1;i=i+1;j--) cout

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect. 1. Stabiliţi care dintre următoarele expresii C/C++ are valoarea 1 dacă şi numai dacă

    numărul întreg memorat în variabila x nu aparţine intervalului (-35,-20]. (4p.)

    a. (x-20) b. (x=-20)

    c. (x-20) d. (x20) Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare. 2. Se consideră algoritmul alăturat, descris în pseudocod. S-a notat cu [z] partea întreagă a numărului real z, iar cux%y restul împărţirii numărului natural x la numărul natural nenul y.

    a) Scrieţi valoarea care va fi afişată dacă se citeşte numărul x=140. (6p.)

    b) Scrieţi o valoare care poate fi citită pentru x (x≠1) astfel încât valoarea afişată să fie 6. (4p.)

    c) Scrieţi programul C/C++ corespunzător algoritmului dat. (10p.)

    d) Scrieţi valorile naturale din intervalul [7,28] care pot fi introduse pentru variabila x, astfel încât, după executarea programului, valoarea afişată să fie 1.

    (6p.)

    citeşte x (număr natural) s 0 f 2 ┌cât timp x>1 execută │ p 0 │┌cât timp x%f=0 execută ││ x [x/f] ││ p p+1 │└■ │┌dacă p≠0 atunci ││ s s+p │└■ │ f f+1 └■ scrie s

    35

    www.bacalaureat2008.info Tot ce trebuie sa stii despre Examenul de Bacalaureat 2008

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect.

    1. În secvenţa de instrucţiuni alăturată, variabilele x şi y sunt de tip int. Care este valoarea pe care trebuie să o aibă iniţial variabila x dacă la finalul executării secvenţei s-a afişat un singur caracter asterisc (*)? (4p.)

    y=x; while(x

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect.

    1. Care este valoarea pe care trebuie să o aibă iniţial variabila întreagă x pentru ca, în urma executării secvenţei alăturate, să se afişeze şirul de mai jos?

    HHHHHH (4p.)

    while (x!=3){ x=x-1; cout

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008

    Proba scrisă la INFORMATICĂ PROBA E, limbajul C/C++

    Specializarea Matematică-informatică intensiv informatică ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect. 1. Care dintre expresiile următoare, scrise în limbajul C/C++, are valoarea 1 dacă şi numai

    dacă valorile variabilelor întregi x şi y sunt numere pare? (4p.)

    a. x-y==0 b. (x+y)%2==0

    c. (x%2==0) || (y%2==0) d. (x%2==0) && (y%2==0) Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare. 2. Se consideră algoritmul alăturat descris în pseudocod. S-a notat cu x%y restul împărţirii numărului natural x la numărul natural nenul y şi cu [z] partea întreagă a numărului real z.

    a) Scrieţi numărul afişat dacă se citesc valorile n=21405 şi k=2. (6p.)

    b) Scrieţi un set de date de intrare astfel încât, în urma executării algoritmului, să se afişeze cea mai mare cifră a valorii citite pentru variabila n. (4p.)

    citeşte n,k (numere naturale, k≤9) i k ┌cât timp i > 0 execută│ n [n/10] │ i i-1 └■ z n%10 scrie z

    c) Scrieţi în pseudocod un algoritm echivalent cu cel dat, în care să se înlocuiască structura cât timp...execută cu o structură repetitivă de tip pentru...execută. (6p.)

    d) Scrieţi programul C/C++ corespunzător algoritmului dat. (10p.)

    38

    www.bacalaureat2008.info Tot ce trebuie sa stii despre Examenul de Bacalaureat 2008

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect. 1. Care este numărul total de atribuiri efectuate la executarea

    secvenţei de instrucţiuni alăturate? (4p.) x=4; y=6; while (y==6) y=y+1; if (x==y) x=x+1;

    a. 4 b. 3 c. 2 d. 5 Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare. 2. Se consideră algoritmul alăturat descris în pseudocod. S-a notat cu x%y restul împărţirii numărului natural x la numărul natural nenul y şi cu [z] partea întreagă a numărului real z.

    a) Scrieţi numărul afişat dacă se citeşte valoarea n=12939. (6p.)

    b) Scrieţi o valoare care poate fi citită pentru variabila n astfel încât, în urma executării algoritmului, valoarea afişată să fie egală cu cea citită. (4p.)

    citeşte n (număr natural) nr 0; p 1 ┌cât timp n≠0 execută │ c n%10 │┌dacă c < 9 atunci ││ c c+1 │└■ │ nr nr+c*p │ p p*10 │ n [n/10] └■ n nr scrie n

    c) Scrieţi în pseudocod un algoritm echivalent cu cel dat, în care să se înlocuiască structura cât timp...execută cu o structură repetitivă de un alt tip. (6p.)

    d) Scrieţi programul C/C++ corespunzător algoritmului dat. (10p.)

    39

    www.bacalaureat2008.info Tot ce trebuie sa stii despre Examenul de Bacalaureat 2008

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect.

    1. Care este valoarea expresiei C/C++ alăturate? (4p.) 50-(100–300/2/(2+3))

    a. -30 b. 70 c. -20 d. 60 Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare.

    2. Se consideră algoritmul alăturat descris în pseudocod. S-a notat cu x%y restul împărţirii numărului natural x la numărul natural nenul y şi cu [z] partea întreagă a numărului real z.

    a) Scrieţi numerele afişate dacă se citeşte valoarea x=168. (6p.)

    b) Scrieţi o valoare care poate fi citită pentru variabila x astfel încât, în urma executării algoritmului, să se afişeze două valori egale. (4p.)

    c) Scrieţi în pseudocod un algoritm echivalent cu cel dat, în care să se înlocuiască fiecare structură cât timp...execută cu câte o structură repetitivă cu test final. (6p.)

    d) Scrieţi programul C/C++ corespunzător algoritmului dat. (10p.)

    citeşte x (număr natural nenul) d 2; y 0; z 0 ┌cât timp x≠ 1 execută │ p 0 │ ┌cât timp x%d=0 execută │ │ p p+1 │ │ x [x/d] │ └■ │ ┌dacă p0 atunci │ │ ┌dacă y=0 atunci y d │ │ └■ │ │ z d │ └■ │ d d+1 └■ scrie y scrie z

    40

    www.bacalaureat2008.info Tot ce trebuie sa stii despre Examenul de Bacalaureat 2008

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect.

    1. Ştiind că variabilele x şi y sunt de tip întreg, care este instrucţiunea prin care variabilei x i se atribuie ultima cifră a numărului natural memorat în variabila y? (4p.)

    a. x=y%10; b. x=x/10; c. y=x/10; d. x=x/10; Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare. 2. Se consideră algoritmul alăturat, descris în pseudocod.

    S-a notat cu [x] partea întreagă numărului real x, iar cu x%y restul împărţirii numărului întreg x la numărul întreg nenul y.

    a) Scrieţi numărul care se afişează dacă se citeşte valoarea 100. (6p.)

    b) Scrieţi cel mai mare număr natural de două cifre care trebuie citit pentru variabila x, astfel încât algoritmul să afişeze exact două valori. (4p.)

    c) Scrieţi în pseudocod un algoritm echivalent cu cel dat, care să conţină o singură structură repetitivă. (6p.)

    d) Scrieţi programul C/C++ corespunzător algoritmului dat (10p.)

    citeşte x (număr natural) d 2 scrie x ┌cât timp x≥d execută │┌cât timp x%d=0 execută ││ x [x/d] ││ scrie x │└■ │ d d+1 └■

    41

    www.bacalaureat2008.info Tot ce trebuie sa stii despre Examenul de Bacalaureat 2008

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect. 1. Ştiind că variabilele x şi y sunt de tip întreg, care este instrucţiunea prin care variabilei x i

    se atribuie cifra zecilor numărului natural cu cel puţin două cifre memorat de variabila y? (4p.)

    a. x=y/10%10; b. x=y%10/10; c. x=y%10; d. x=x/100; Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare. 2. Se consideră algoritmul alăturat, descris în pseudocod. S-a notat cu [x] partea întreagă a numărului real x, iar cu x%y restul împărţirii numărului natural x la numărul natural y.

    a) Scrieţi valoarea care se va afişa la finalul executării algoritmului dacă se citesc valorile x=15 şi y=25. (6p.)

    b) Dacă pentru y se citeşte valoarea 10, scrieţi cel mai mare număr natural de cel mult două cifre care trebuie citit pentru variabila x astfel încât la finalul executării algoritmului să se afişeze valoarea 20. (4p.)

    c) Scrieţi în pseudocod un algoritm echivalent cu cel dat în care structura cât timp...execută să fie înlocuită cu o structură repetitivă cu test final. (6p.)

    d) Scrieţi programul C/C++ corespunzător algoritmului dat. (10p.)

    citeşte x,y (numere naturale) ┌cât timp y>0 execută │ z x%y │ x y │ y z └■ scrie x

    42

    www.bacalaureat2008.info Tot ce trebuie sa stii despre Examenul de Bacalaureat 2008

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect.

    1. Care este instrucţiunea prin care variabilei x i se atribuie valoarea sumei cifrelor numărului natural format din exact trei cifre, memorat de variabila y? (4p.)

    a. x=y/100+y/10%10+y%10; b. x=y+y/10+y/100;

    c. x=y%10+y%10/10+y/100; d. x=y%10+y%100+y%1000; Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare. 2. Se consideră algoritmul alăturat, descris în pseudocod.

    S-a notat cu x%y restul împărţirii numărului natural x la numărul natural y.

    a) Scrieţi valoarea pe care o va afişa algoritmul dacă se citesc, în această ordine, numerele 30 şi 25. (6p.)

    b) Dacă se citeşte pentru variabila y valoarea 26, scrieţi toate numerele naturale de cel mult două cifre care pot fi citite pentru variabila x, astfel încât la finalul executării algoritmului să se afişeze valoarea 13. (4p.)

    c) Scrieţi în pseudocod un algoritm care sa fie echivalent cu cel dat în care structura cât timp...execută să fie înlocuită cu o structură repetitivă cu test final. (6p.)

    d) Scrieţi programul C/C++ corespunzător algoritmului dat. (10p.)

    citeşte x,y (numere naturale) ┌cât timp x*y≠0 executã │┌daca x>y atunci ││ x x%y ││altfel ││ y y%x │└■ └■ scrie x+y

    43

    www.bacalaureat2008.info Tot ce trebuie sa stii despre Examenul de Bacalaureat 2008

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect. 1. Care este instructiunea prin care variabilei x i se atribuie valoarea cifrei sutelor numărului

    natural cu cel puţin 4 cifre memorat în variabila y? (4p.)

    a. x=y/100%10; b. x=y/10/10; c. x=y%100; d. x=y%10/10; Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare. 2. Se consideră algoritmul alăturat, descris în pseudocod. S-a notat cu x%y restul împarţirii numărului natural x la numărul natural nenul y.

    a) Scrieţi numărul care se afişează dacă se citeşte valoarea 274. (6p.)

    b) Scrieţi toate numerele naturale de câte 3 cifre care pot fi citite pentru variabila x, astfel încât, la finalul executării algoritmului să se afişeze valoarea 1111. (4p.)

    c) Scrieţi în pseudocod un algoritm echivalent cu cel dat în care structura cât timp...execută să fie înlocuită cu o structură repetitivă cu test final. (6p.)

    d) Scrieţi programul C/C++ corespunzător algoritmului dat. (10p.)

    citeşte x (număr natural) y 0 ┌cât timp x>y executã │ y y*10+9-x%10; └■ scrie y

    44

    www.bacalaureat2008.info Tot ce trebuie sa stii despre Examenul de Bacalaureat 2008

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect. 1. Care este instrucţiunea prin care variabilei x i se atribuie numărul obţinut prin inversarea

    ordinii cifrelor numărului natural format din exact 2 cifre, memorat în variabila y? (4p.)

    a. x=y%10*10+y/10; b. x=y/10*10+y%10;

    c. x=y%10+y/10*10; d. x=y%10+y/10; Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare. 2. Se consideră algoritmul alăturat, descris în pseudocod: S-a notat cu x%y restul împărţirii numărului natural x la numărul natural y.

    a) Scrieţi valoarea care va fi afişată de algoritm dacă se citesc, în această ordine, valorile 12 şi 3. (6p.)

    b) Dacă valoarea citită pentru variabila y este 19, scrieţi care este cea mai mare valoare care trebuie citită pentru x, astfel încât algoritmul să afişeze numărul 0. (4p.)

    c) Scrieţi în pseudocod un algoritm echivalent cu cel dat în care să se înlocuiască structura cât timp...execută cu o structură repetitivă cu test final. (6p.)

    d) Scrieţi programul C/C++ corespunzător algoritmului dat. (10p.)

    citeşte x,y (numere naturale) z 1 t 0 ┌cât timp x≥z execută │┌dacă x%z=y atunci ││ t z │└■ │ z z+1 └■ scrie t

    45

    www.bacalaureat2008.info Tot ce trebuie sa stii despre Examenul de Bacalaureat 2008

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect.

    1. Variabila întreagă n memorează un număr natural impar. Care dintre următoarele expresii C/C++ are valoarea 1? (4p.)

    a. !(n%2) b. n%2==0 c. n%2!=0 d. !((n+1)%2==0) Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare. 2. Se consideră algoritmul alăturat, descris în pseudocod. S-a notat cu x%y restul împărţirii numărului întreg x la numărul întreg nenul y şi cu [a] partea întreagă a numărului real a.

    a) Scrieţi valoarea afişată dacă se citeşte numărul n=10326. (6p.)

    b) Scrieţi pentru câte numere de forma , unde a este cifra sutelor, b este cifra unităţilor şi a≠b, valoarea afişată este 1. (4p.)

    c) Scrieţi programul C/C++ corespunzător algoritmului dat. (10p.)

    d) Scrieţi în pseudocod un algoritm echivalent cu cel dat în care să se înlocuinască structura cât timp...execută cu o structură repetitivă cu test final. (6p.)

    citeşte n (număr natural) s 0 nr 0 ┌cât timp n≠0 execută │ ┌dacă n%2=0 atunci │ │ s s*10+n%10 │ └■ │ n [n/10] └■ ┌dacă s≠0 atunci │ nr 1 └■ scrie nr

    46

    www.bacalaureat2008.info Tot ce trebuie sa stii despre Examenul de Bacalaureat 2008

  • Ministerul Educaţiei, Cercetării şi Tineretului – Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

    INFORMATICĂ, limbajul C/C++ Subiectul I Specializarea Matematică-informatică intensiv informatică

    EXAMENUL DE BACALAUREAT – 2008 Proba scrisă la INFORMATICĂ

    PROBA E, limbajul C/C++ Specializarea Matematică-informatică intensiv informatică

    ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ

    (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată).

    Subiectul I (30 de puncte) Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect.

    1. Care dintre următoarele variabile nu îşi modifică valoarea în urma executării secvenţei de instrucţiuni alăturate, oricare ar fi valorile lor iniţiale? (a,b,c sunt variabile de tip int). (4p.)

    c=2*a-b; a=a-b; a=c-a; b=2*a-c;

    a. niciuna b. doar c c. doar a şi c d. doar a şi b Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare. 2. Se consideră algoritmul alăturat, descris în pseudocod. S-a notat cu x%y restul împărţirii numărului întreg x la numărul întreg nenul y şi cu [a] partea întreagă a numărului real a.

    a) Scrieţi valoarea afişată dacă se citeşte numărul 27349. (10p.)

    b) Scrieţi câte numere naturale de trei cifre pot fi citite pentru variabila n, astfel încât valoarea afişată să fie 3. (4p.)

    c) Scrieţi în pseudocod un algoritm echivalent cu cel dat în care să se