Transcript
  • 1 Boson NetSim Lab Manual

    SWITCH Lab: EtherChannel Negotiation

    Protocols Part II: LACP

    ObjectiveYou will plan, implement, and verify Layer 2 EtherChannel con gurations in this lab by con guring EtherChannel

    between two switches using the PAgP negotiation protocol.

    Lab TopologyThe Topology diagram below represents the NetMap in the Simulator:

    CSW1DSW1

    PC1

    ASW1

    Gi0/1

    Gi0/2

    Gi0/1

    Gi0/2

    Fa0/1

    Fa0/10

    Fa0/1

    Fa0/10

    Fa0/11

    Command Summary

    Command Description

    channel-group port-channel-number mode

    {on | auto [non-silent] | desirable [non-

    silent] on | active | passive}

    assigns an Ethernet interface to an EtherChannel group

    channel-protocol {lacp | pagp} con gures the EtherChannel negotiation protocol for the

    interface

    interface range fastethernet slot/starting-

    port - ending-port

    con gures a range of interfaces

    interface type number changes from global con guration mode to interface

    con guration mode

    lacp port-priority priority-value con gures the LACP priority for the interface

    lacp system-priority priority-value con gures the LACP priority for the system

    show cdp neighbors displays information about directly connected neighbors

    show etherchannel [channel-group-number]

    {detail | load-balance | port | port-channel |

    summary | protocol}

    displays EtherChannel information for a channel

    show interfaces [type number] displays the interfaces Data Link layer status; when the

    type and number parameters are included, displays detailed

    information about the speci ed interface

    show interfaces trunk displays port and module interface-trunk information

    show ip interface brief displays a brief summary of interface status and con guration

    show running-con g displays the active con guration le

    switchport mode {access | dynamic {auto |

    desirable} | trunk}

    con gures the virtual LAN (VLAN) membership mode of a port

    switchport trunk encapsulation dot1q con gures trunk for 802.1Q encapsulation

    Lab ID: 8.8K1112A195.SWP.1

  • 2 Boson NetSim Lab Manual

    Lab Tasks

    Task 1: Plan EtherChannel Con gurations

    This task involves planning Layer 2 EtherChannel con gurations using negotiation protocols. In this lab, you will

    be assigning physical interfaces to a channel group and using LACP to form an EtherChannel between ASW1

    and DSW1.

    1. What command could you issue to determine the number of links that are available to form an

    EtherChannel? ______________________________________________________________________

    2. Which protocol is de ned in the IEEE 802.3ad standard, and when should it be used? ______________

    3. Which modes does LACP support? List any factors that would determine which mode you would use.

    __________________________________________________________________________________

    __________________________________________________________________________________

    4. How many interfaces can be bundled in an EtherChannel using LACP? What happens to additional

    interfaces once this limit is met? ________________________________________________________

    __________________________________________________________________________________

    5. Can more than one EtherChannel protocol be used in the same EtherChannel? ___________________

    6. What happens to the physical interfaces when you make a change to a port-channel interface? ______

    __________________________________________________________________________________

    Task 2: Review Initial Con gurations

    This task involves performing Layer 2 EtherChannel con gurations.

    1. Determine the number of links that can be con gured as part of the port-channel group.

    2. Observe the line and protocol state of each interface on ASW1 and DSW1.

    3. Verify that an active trunk link exists between ASW1 and DSW1. Which trunk encapsulation type are both

    switches using? _____________________________________________________________________

    4. When the lab is loaded, all 20 interfaces have identical con gurations. Why is this important to know?

    __________________________________________________________________________________

    Task 3: Con gure EtherChannel by Using LACP

    This task involves con guring the appropriate interfaces to use LACP as the EtherChannel negotiation protocol.

    1. Con gure the FastEthernet 0/1 - 10 interfaces of ASW1 and DSW1 to use LACP as the EtherChannel

    negotiation protocol.

  • 3 Boson NetSim Lab Manual

    2. Con gure the FastEthernet 0/1 - 10 interfaces on ASW1 and DSW1 as members of channel-group 1 by

    using the passive mode.

    3. Verify that the new, automatically created Port-Channel 1 interface exists on ASW1 and DSW1.

    4. Determine the administrative mode of the newly created port-channel interface.

    5. Con gure the Port-Channel 1 interface to trunk unconditionally using 802.1Q as the trunk encapsulation.

    6. Use the show etherchannel summary command to view details about the channel group. Are

    FastEthernet 0/1 - 10 bundled in the port channel? If not, why? ________________________________

    __________________________________________________________________________________

    7. Con gure FastEthernet 0/1 - 10 on ASW1 to use LACP active mode.

    8. Use the show ip interface brief command to verify that the line and protocol state of Port-Channel 1 are

    both up.

    9. Use the show etherchannel summary command to view details about the channel group. List any

    interfaces that are not in a bundled state. What state are these interfaces in and why? ______________

    __________________________________________________________________________________

    10. Determine the LACP port priority for interfaces in the channel group.

    Task 4: Con gure LACP Priorities

    1. On ASW1, change the LACP port priority of FastEthernet 0/9 to 100.

    2. Use the show etherchannel summary command on ASW1 to display details about the channel group. Is

    FastEthernet 0/9 in a bundled state? _____________________________________________________

    3. On ASW1, use the show etherchannel port command to display details about each interface that is a

    member of a channel group, including the device ID of its partner. Repeat this step on DSW1. What is the

    signi cance of the partner device ID? ____________________________________________________

    __________________________________________________________________________________

    4. Change the LACP system priority of ASW1 to 100.

    5. Use the show etherchannel summary command on ASW1. Is FastEthernet 0/9 in a bundled state?

    Have any interfaces changed to hot standby? ______________________________________________

  • 4 Boson NetSim Lab Manual

    Lab Solutions

    Task 1: Plan Ethernet Con gurations

    This task involves planning EtherChannel con gurations.

    1. You should issue the show cdp neighbors command to determine the number of links that are available

    to form an EtherChannel. EtherChannel requires a minimum of 2 links between devices.

    2. Link Aggregation Control Protocol (LACP) is de ned in the Institute of Electrical and Electronics

    Engineers (IEEE) 802.3ad standard. Because LACP is a standards-based protocol, it can be used

    between Cisco and non-Cisco switches. Conversely, Port Aggregation Protocol (PAgP) is a Cisco

    proprietary protocol and can only be used to create EtherChannels between Cisco switches. Either one

    of these protocols will allow a switch to learn its partners capabilities and dynamically group identically

    con gured interfaces into a single logical link.

    3. LACP can be con gured in either active or passive mode. Active mode places an interface into a state

    where it will initiate negotiation with its partner by sending out LACP packets. Passive mode places

    an interface into a state where it will respond to LACP packets but not initiate any negotiation. Placing

    an interface in passive mode will minimize LACP traf c; however, if both ends of a link are con gured

    in passive mode, no negotiation can take place and the interface will not be bundled. The table below

    describes the different modes of LACP and PAgP:

    4. Both PAgP and LACP support up to 8 active links between devices in a negotiated channel. LACP allows

    a maximum of 16 ports to be con gured in a channel, but only 8 can be active at any given time. Non-

    active links in an LACP bundle are placed in hot standby mode, and if any active link becomes inactive,

    one of the hot standby links will change to active mode and take its place in the channel.

    LACP uses the port priority and port ID values to determine which hot standby port will become active.

    The LACP port priority is set to 32768 by default for all interfaces; however, you can change this value

    to specify which hot standby links become active rst. A lower LACP priority value will place an interface

    ahead of others when active ports are being selected. If hot standby ports are con gured with the same

    LACP port priority then ports with lower port numbers will be selected rst.

  • 5 Boson NetSim Lab Manual

    5. All ports in an EtherChannel must be con gured to use the same protocol: either PAgP or LACP, not both.

    Additionally, all ports must be con gured with the same speed and duplex settings. Ports in an LACP

    channel that are con gured for half-duplex mode are placed in a suspended state and not used in the

    channel.

    6. When you make a change to a port-channel interface, the changes are implemented on all physical

    interfaces. Conversely, if you make a con guration change on a physical interface that is part of the

    channel group, the change is not implemented on any of the other physical interfaces in the channel

    group or the groups port-channel interface. Making a change to a physical interface might unbundle it

    from the port channel and place it in a stand-alone state.

    Task 2: Review Initial Con gurations

    This task involves implementing the planned EtherChannel con gurations and enabling LACP as the negotiation

    protocol.

    1. By issuing the show cdp neighbors command on ASW1, you can determine that ports FastEthernet

    0/1 - 10 form links to the FastEthernet 0/1 - 10 ports on DSW1. These 20 ports form 10 links that can be

    con gured to form a channel group between ASW1 and DSW1. Below is sample output from ASW1:

    ASW1#show cdp neighbors

    Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge

    S -Switch, H - Host, i - IGMP, r - Repeater

    Device ID Local Intrfce Holdtme Capability Platform Port ID

    DSW1 Fas0/1 129 T S 3550 Fas 0/1

    DSW1 Fas0/2 129 T S 3550 Fas 0/2

    DSW1 Fas0/3 129 T S 3550 Fas 0/3

    DSW1 Fas0/4 129 T S 3550 Fas 0/4

    DSW1 Fas0/5 129 T S 3550 Fas 0/5

    DSW1 Fas0/6 129 T S 3550 Fas 0/6

    DSW1 Fas0/7 129 T S 3550 Fas 0/7

    DSW1 Fas0/8 129 T S 3550 Fas 0/8

    DSW1 Fas0/9 129 T S 3550 Fas 0/9

    DSW1 Fas0/10 129 T S 3550 Fas 0/10

  • 6 Boson NetSim Lab Manual

    2. You can infer from the output of the show cdp neighbors command that FastEthernet 0/1 - 10 are up

    and connected to their respective DSW1 ports; however, to verify the line and protocol state, you should

    use the show ip interface brief command. Below is a sample output from ASW1:

    ASW1#show ip interface brief

    Interface IP-Address OK? Method Status Protocol

    Vlan 1 unassigned YES unset up up

    FastEthernet0/1 unassigned YES unset up up

    FastEthernet0/2 unassigned YES unset up up

    FastEthernet0/3 unassigned YES unset up up

    FastEthernet0/4 unassigned YES unset up up

    FastEthernet0/5 unassigned YES unset up up

    FastEthernet0/6 unassigned YES unset up up

    FastEthernet0/7 unassigned YES unset up up

    FastEthernet0/8 unassigned YES unset up up

    FastEthernet0/9 unassigned YES unset up up

    FastEthernet0/10 unassigned YES unset up up

    FastEthernet0/11 unassigned YES unset up up

    FastEthernet0/12 unassigned YES unset down down

    3. You can issue the show interfaces trunk command to observe the trunk state and encapsulation type of

    each port. All of the ports should display that they have negotiated 802.1Q encapsulation. Sample output

    is shown below:

    ASW1#show interfaces trunk

    Port Mode Encapsulation Status Native vlan

    Fa0/1 desirable 802.1q trunking 1

    Fa0/2 desirable 802.1q trunking 1

    Fa0/3 desirable 802.1q trunking 1

    Fa0/4 desirable 802.1q trunking 1

    Fa0/5 desirable 802.1q trunking 1

    Fa0/6 desirable 802.1q trunking 1

    Fa0/7 desirable 802.1q trunking 1

    Fa0/8 desirable 802.1q trunking 1

    Fa0/9 desirable 802.1q trunking 1

    Fa0/10 desirable 802.1q trunking 1

    4. It is important to know that all 20 interfaces have identical con gurations when the lab is loaded because

    ports that form a channel group must have identical con gurations.

  • 7 Boson NetSim Lab Manual

    Task 3: Con gure EtherChannel by Using LACP

    1. You should issue the following commands to con gure LACP as the negotiation protocol on the interfaces

    that form the links between ASW1 and DSW1:

    ASW1(config)#interface range fastethernet 0/1 10

    ASW1(config-if-range)#channel-protocol lacp

    DSW1(config)#interface range fastethernet 0/1 10

    DSW1(config-if-range)#channel-protocol lacp

    2. You should issue the following commands to add the interfaces of ASW1 and DSW1 to channel-group 1

    and enable LACP passive mode:

    ASW1(config-if-range)#channel-group 1 mode passive

    DSW1(config-if-range)#channel-group 1 mode passive

    3. You should issue the show interfaces port-channel 1 command to verify that the Port-Channel 1

    interface exists on ASW1 and DSW1. Below is sample output from ASW1:

    ASW1#show interfaces port-channel 1

    Port-channel1 is down, line protocol is down

    Hardware is EtherChannel, address is 000C.3267.4215 (bia 000C.3267.4215)

    MTU 1500 bytes, BW 1000 Kbit, DLY 100 usec,

    reliability 255/255, txload 1/255, rxload 1/255

    Auto-duplex, Auto-speed

    Encapsulation ARPA, loopback not set

    ARP type: ARPA, ARP Timeout 04:00:00

    Last input 02:29:44, output never, output hang never

    Last clearing of show interface counters never

    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

    Queuing strategy: fifo

    Output queue :0/40 (size/max)

    5 minute input rate 0 bits/sec, 0 packets/sec

    5 minute output rate 0 bits/sec, 0 packets/sec

    269 packets input, 71059 bytes, 0 no buffer

    Received 6 broadcasts, 0 runts, 0 giants, 0 throttles

    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

    7290 packets output, 429075 bytes, 0 underruns

    0 output errors, 3 interface resets

    0 output buffer failures, 0 output buffers swapped out

  • 8 Boson NetSim Lab Manual

    4. You should issue the show interfaces port-channel 1 switchport command to determine the

    administrative mode con gured on ASW1 and DSW1. The following is sample output from ASW1:

    ASW1#show interfaces port-channel 1 switchport

    Name: Po1

    Switchport: Enabled

    Administrative mode: dynamic desirable

    Operational mode: trunk

    Administrative Trunking Encapsulation: dot1q

    Operational Trunking Encapsulation: dot1q

    Negotiation of Trunking: On

    Access Mode VLAN: 1 (default)

    Trunking Native Mode VLAN: 1 (default)

    Voice VLAN: none

    Trunking VLANs Enabled: ALL

    Pruning VLANs Enabled: 2-1001

    Protected: false

    Appliance trust: none

    5. Once you create a Port-Channel interface, all interfaces in the channel group are con gured from

    the port-channel interface for the group. You should issue the following commands to change the

    administrative mode to form a trunk unconditionally and force the encapsulation to 802.1Q on the Port-

    Channel 1 interface of the switches:

    ASW1(config)#interface port-channel 1

    ASW1(config-if)#switchport trunk encapsulation dot1q

    ASW1(config-if)#switchport mode trunk

    DSW1(config)#interface port-channel 1

    DSW1(config-if)#switchport trunk encapsulation dot1q

    DSW1(config-if)#switchport mode trunk

  • 9 Boson NetSim Lab Manual

    6. Below is sample output of the show etherchannel summary command for both ASW1 and DSW1. From

    this output, you can observe that the ags (DS) associated with the Port-Channel 1 interface indicate

    that the port channel is down (D) and running in Layer 2 mode (S). The FastEthernet 0/1 - 10 interfaces

    can be observed to be running in a stand-alone state (I). This means that the physical interfaces are

    not bundled in the port channel and are sending traf c independently. In step 2, you con gured the ports

    on ASW1 and DSW1 to use LACP passive mode. This means that neither end of the EtherChannel will

    initiate sending LACP packets and successful EtherChannel negotiation cannot occur. Sample output is

    shown below:

    ASW1#show etherchannel summary

    Flags: D - down P - bundled in port-channel

    I - stand-alone s - suspended

    H - Hot-standby (LACP only)

    R - Layer3 S - Layer2

    U - in use f - failed to allocate aggregator

    M - not in use, minimum links not met

    u - unsuitable for bundling

    w - waiting to be aggregated

    d - default port

    Number of channel-groups in use: 1

    Number of aggregators: 1

    Group Port-channel Protocol Ports

    ---------------------------------------------------------------

    1 Po1(DS) LACP Fa0/1(I) Fa0/2(I) Fa0/3(I) Fa0/4(I)

    Fa0/5(I) Fa0/6(I) Fa0/7(I) Fa0/8(I) Fa0/9(I) Fa0/10(I)

    DSW1#show etherchannel summary

    Flags: D - down P - bundled in port-channel

    I - stand-alone s - suspended

    H - Hot-standby (LACP only)

    R - Layer3 S - Layer2

    U - in use f - failed to allocate aggregator

    M - not in use, minimum links not met

    u - unsuitable for bundling

    w - waiting to be aggregated

    d - default port

    Number of channel-groups in use: 1

    number of aggregators: 1

    Group Port-channel Protocol Ports

    ---------------------------------------------------------------

    1 Po1(DS) LACP Fa0/1(I) Fa0/2(I) Fa0/3(I) Fa0/4(I)

    Fa0/5(I) Fa0/6(I) Fa0/7(I) Fa0/8(I) Fa0/9(I) Fa0/10(I)

  • 10 Boson NetSim Lab Manual

    7. In order to successfully negotiate an EtherChannel using LACP, at least one end of the link should be

    con gured to use active mode. You should issue the following commands on ASW1 to enable active

    mode for interfaces FastEthernet 0/1 - 10:

    ASW1(config)#interface range fastethernet 0/1 - 10

    ASW1(config-if-range)#channel-group 1 mode active

    8. You can verify that the line and protocol states of the Port-Channel 1 interface are both up using the

    show ip interface brief command. Below is sample output from ASW1:

    ASW1#show ip interface brief

    Interface IP-Address OK? Method Status Protocol

    Vlan 1 unassigned YES unset up up

    FastEthernet0/1 unassigned YES unset up up

    FastEthernet0/2 unassigned YES unset up up

    FastEthernet0/3 unassigned YES unset up up

    FastEthernet0/4 unassigned YES unset up up

    FastEthernet0/5 unassigned YES unset up up

    FastEthernet0/6 unassigned YES unset up up

    FastEthernet0/7 unassigned YES unset up up

    FastEthernet0/8 unassigned YES unset up up

    FastEthernet0/9 unassigned YES unset up up

    FastEthernet0/10 unassigned YES unset up up

    FastEthernet0/11 unassigned YES unset up up

    FastEthernet0/12 unassigned YES unset down down

    Port-channel1 unassigned YES unset up up

    9. The output of the show etherchannel summary command should now indicate that the Port-Channel

    1 interface is up. The (P) ag associated with the FastEthernet 0/1 - 8 interfaces indicates that these

    interfaces are now bundled in the port channel. The (H) ag associated with FastEthernet 0/9 and

    FastEthernet 0/10 indicates that these interfaces are in a hot standby state. The (US) ags for the Port-

    Channel 1 interface indicate that the port channel is in use (U) and operating in Layer 2 mode (S). LACP

    allows up to 8 ports to be active and the rest are placed in hot standby.

    ASW1#show etherchannel summary

    Flags: D - down P - bundled in port-channel

    I - stand-alone s - suspended

    H - Hot-standby (LACP only)

    R - Layer3 S - Layer2

    U - in use f - failed to allocate aggregator

    M - not in use, minimum links not met

    u - unsuitable for bundling

    w - waiting to be aggregated

    d - default port

    Number of channel-groups in use: 1

    Number of aggregators: 1

    Group Port-channel Protocol Ports

    ---------------------------------------------------------------

    1 Po1(US) LACP Fa0/1(P) Fa0/2(P) Fa0/3(P) Fa0/4(P)

    Fa0/5(P) Fa0/6(P) Fa0/7(P) Fa0/8(P) Fa0/9(H) Fa0/10(H)

    (continued on next page)

  • 11 Boson NetSim Lab Manual

    (continued from previous page)

    DSW1#show etherchannel summary

    Flags: D - down P - bundled in port-channel

    I - stand-alone s - suspended

    H - Hot-standby (LACP only)

    R - Layer3 S - Layer2

    U - in use f - failed to allocate aggregator

    M - not in use, minimum links not met

    u - unsuitable for bundling

    w - waiting to be aggregated

    d - default port

    Number of channel-groups in use: 1

    Number of aggregators: 1

    Group Port-channel Protocol Ports

    ---------------------------------------------------------------

    1 Po1(US) LACP Fa0/1(P) Fa0/2(P) Fa0/3(P) Fa0/4(P)

    Fa0/5(P) Fa0/6(P) Fa0/7(P) Fa0/8(P) Fa0/9(H) Fa0/10(H)

    10. You should issue the show etherchannel port command to determine that all of the interfaces are

    con gured with the default LACP port priority (32768), which causes LACP to select active interfaces

    based on the lowest port number. The following is partial sample output from DSW1:

    DSW1#show etherchannel port

    Channel-group listing:

    ----------------------

    Group: 1

    ----------

    Ports in the group:

    -------------------

    Port: Fa0/1

    ------------

    Port state = Up Mstr In-Bndl

    Channel group = 1 Mode = Passive Gccchange = 0

    Port-channel = Po1 GC = 0x00000101 Psuedo port-channel = Po1

    Port index = 1 Load = 0x00 Protocol = LACP

    Flags: S - Device is sending Slow LACPDUs F - Device is sending fast

    LACPDUs.

    A - Device is in active mode. P - Device is in passive mode.

    Local information:

    LACP port Admin Oper Port Port

    Port Flags State Priority Key Key Number State

    Fa0/1 SP bndl 32768 0x3 0x3 0x2 0x3C

    (continued on next page)

  • 12 Boson NetSim Lab Manual

    (continued from previous page)

    Partners information:

    LACP port Admin Oper Port Port

    Port Flags Priority Dev ID Age key Key Number State

    Fa0/1 SA 32768 000C.3388.4866 20s 0x0 0x3 0x2 SA

    Age of the port in the current state:

    Port: Fa0/2

    ------------

    Port state = Up Mstr In-Bndl

    Channel group = 1 Mode = Passive Gccchange = 0

    Port-channel = Po1 GC = 0x00000101 Psuedo port-channel = Po1

    Port index = 2 Load = 0x00 Protocol = LACP

    Flags: S - Device is sending Slow LACPDUs F - Device is sending fast

    LACPDUs.

    A - Device is in active mode. P - Device is in passive mode.

    Task 4: Con gure LACP Priorities

    1. Use the following commands to change the LACP port-priority of FastEthernet 0/9 on ASW1. By

    con guring a port priority lower than the other interfaces you can make sure that FastEthernet 0/9 is

    selected as an active interface and not placed in hot standby. You can verify your con guration by issuing

    the show etherchannel port command.

    ASW1(config)#interface fastethernet 0/9

    ASW1(config-if)#lacp port-priority 100

    ASW1#show etherchannel port

    Port: Fa0/9

    ------------

    Port state = Up Mstr In-Bndl

    Channel group = 1 Mode = Active Gccchange = 0

    Port-channel = Po1 GC = 0x00000101 Psuedo port-channel = Po1

    Port index = 9 Load = 0x00 Protocol = LACP

    Flags: S - Device is sending Slow LACPDUs F - Device is sending fast

    LACPDUs.

    A - Device is in active mode. P - Device is in passive mode.

    Local information:

    LACP port Admin Oper Port Port

    Port Flags State Priority Key Key Number State

    Fa0/9 SA hot-sby 100 0x3 0x3 0x10 0x3D

    (continued on next page)

  • 13 Boson NetSim Lab Manual

    (continued from previous page)

    Partners information:

    LACP port Admin Oper Port Port

    Port Flags Priority Dev ID Age key Key Number State

    Fa0/9 SP 32768 000C.1380.3538 10s 0x0 0x3 0x10 SP

    Age of the port in the current state:

    2. The output of the show etherchannel summary command indicates that the FastEthernet 0/9 interface

    is still in a hot standby state, even though you have changed the port priority so that it would be selected

    to become active before the other interfaces. Sample output is shown below:

    ASW1#show etherchannel summary

    Flags: D - down P - bundled in port-channel

    I - stand-alone s - suspended

    H - Hot-standby (LACP only)

    R - Layer3 S - Layer2

    U - in use f - failed to allocate aggregator

    M - not in use, minimum links not met

    u - unsuitable for bundling

    w - waiting to be aggregated

    d - default port

    Number of channel-groups in use: 1

    Number of aggregators: 1

    Group Port-channel Protocol Ports

    ---------------------------------------------------------------

    1 Po1(US) LACP Fa0/1(P) Fa0/2(P) Fa0/3(P) Fa0/4(P)

    Fa0/5(P) Fa0/6(P) Fa0/7(P) Fa0/8(P) Fa0/9(H) Fa0/10(H)

  • 14 Boson NetSim Lab Manual

    3. LACP allows only one switch to make decisions about which interfaces are actively participating in the

    EtherChannel. The LACP system priority and the device ID (switch MAC address) are used to determine

    which switch is the decision maker. Both ASW1 and DSW1 are con gured with default LACP system

    priority values (32768) so in this case the device with the lower device ID will be the decision maker. By

    using the show etherchannel port command on ASW1, you can observe that the device ID of its partner

    (DSW1) is 000C.1380.3538. The same command is used on DSW1 to observe that the device ID of

    ASW1 is 000C.3388.4866. Since DSW1 has the lower device ID it will decide which interfaces are active,

    regardless of the port priority con gurations on ASW1. Sample output is shown below:

    ASW1#show etherchannel port

    Channel-group listing:

    ----------------------

    Group: 1

    ----------

    Ports in the group:

    -------------------

    Port: Fa0/1

    ------------

    Port state = Up Mstr In-Bndl

    Channel group = 1 Mode = Active Gccchange = 0

    Port-channel = Po1 GC = 0x00000101 Psuedo port-channel = Po1

    Port index = 1 Load = 0x00 Protocol = LACP

    Flags: S - Device is sending Slow LACPDUs F - Device is sending fast

    LACPDUs.

    A - Device is in active mode. P - Device is in passive mode.

    Local information:

    LACP port Admin Oper Port Port

    Port Flags State Priority Key Key Number State

    Fa0/1 SA bndl 32768 0x3 0x3 0x2 0x3D

    Partners information:

    LACP port Admin Oper Port Port

    Port Flags Priority Dev ID Age key Key Number State

    Fa0/1 SP 32768 000C.1380.3538 24s 0x0 0x3 0x2 SP

    (continued on next page)

  • 15 Boson NetSim Lab Manual

    (continued from previous page)

    DSW1#show etherchannel port

    Channel-group listing:

    ----------------------

    Group: 1

    ----------

    Ports in the group:

    -------------------

    Port: Fa0/1

    ------------

    Port state = Up Mstr In-Bndl

    Channel group = 1 Mode = Passive Gccchange = 0

    Port-channel = Po1 GC = 0x00000101 Psuedo port-channel = Po1

    Port index = 1 Load = 0x00 Protocol = LACP

    Flags: S - Device is sending Slow LACPDUs F - Device is sending fast

    LACPDUs.

    A - Device is in active mode. P - Device is in passive mode.

    Local information:

    LACP port Admin Oper Port Port

    Port Flags State Priority Key Key Number State

    Fa0/1 SP bndl 32768 0x3 0x3 0x2 0x3C

    Partners information:

    LACP port Admin Oper Port Port

    Port Flags Priority Dev ID Age key Key Number State

    Fa0/1 SA 32768 000C.3388.4866 29s 0x0 0x3 0x2 SA

    4. By changing the LACP system priority value on ASW1, you can make it the decision maker about active

    ports in the EtherChannel. You should issue the following command on ASW1 to change the system

    priority from 32768 (default) to 100:

    ASW1(config)#lacp system-priority 100

  • 16 Boson NetSim Lab Manual

    5. The output of the show etherchannel summary command should now indicate that FastEthernet 0/9 is

    bundled and FastEthernet 0/8 has been placed in hot standby. Sample output is shown below:

    ASW1#show etherchannel summary

    Flags: D - down P - bundled in port-channel

    I - stand-alone s - suspended

    H - Hot-standby (LACP only)

    R - Layer3 S - Layer2

    U - in use f - failed to allocate aggregator

    M - not in use, minimum links not met

    u - unsuitable for bundling

    w - waiting to be aggregated

    d - default port

    Number of channel-groups in use: 1

    Number of aggregators: 1

    Group Port-channel Protocol Ports

    ---------------------------------------------------------------

    1 Po1(US) LACP Fa0/1(P) Fa0/2(P) Fa0/3(P) Fa0/4(P)

    Fa0/5(P) Fa0/6(P) Fa0/7(P) Fa0/8(H) Fa0/9(P) Fa0/10(H)

  • 17 Boson NetSim Lab Manual

    Sample Con guration Scripts

    ASW1 ASW1 (continued)

    ASW1#show running-config

    Building configuration...

    Current configuration : 1739 bytes

    !

    Version 12.3

    service timestamps debug uptime

    service timestamps log uptime

    no service password-encryption

    !

    hostname ASW1

    ip cef

    !

    ip subnet-zero

    !

    no ip domain-lookup

    lacp system-priority 100

    spanning-tree mode pvst

    spanning-tree extend system-id

    !

    interface Port-channel1

    switchport mode trunk

    !

    interface FastEthernet0/1

    switchport mode trunk

    channel-protocol lacp

    channel-group 1 mode active

    !

    interface FastEthernet0/2

    switchport mode trunk

    channel-protocol lacp

    channel-group 1 mode active

    !

    interface FastEthernet0/3

    switchport mode trunk

    channel-protocol lacp

    channel-group 1 mode active

    !

    interface FastEthernet0/4

    switchport mode trunk

    channel-protocol lacp

    channel-group 1 mode active

    !

    interface FastEthernet0/5

    switchport mode trunk

    channel-protocol lacp

    channel-group 1 mode active

    !

    interface FastEthernet0/6

    switchport mode trunk

    channel-protocol lacp

    channel-group 1 mode active

    !

    interface FastEthernet0/7

    switchport mode trunk

    channel-protocol lacp

    channel-group 1 mode active

    !

    interface FastEthernet0/8

    switchport mode trunk

    channel-protocol lacp

    channel-group 1 mode active

    !

    interface FastEthernet0/9

    switchport mode trunk

    lacp port-priority 100

    channel-protocol lacp

    channel-group 1 mode active

    !

    interface FastEthernet0/10

    switchport mode trunk

    channel-protocol lacp

    channel-group 1 mode active

    !

    interface FastEthernet0/11

    !

    interface FastEthernet0/12

    !

    interface Vlan 1

    no ip address

    no ip route-cache

    !

    ip classless

    no ip http server

    channel-group 1 mode active

    !

    line con 0

    line aux 0

    line vty 0 15

    !

    no scheduler allocate

    end

    Copyright 19962012 Boson Software, LLC. All rights reserved. NetSim software and documentation are protected by copyright law.

  • 18 Boson NetSim Lab Manual

    DSW1 DSW1 (continued)

    DSW1#show running-config

    Building configuration...

    Current configuration : 2318 bytes

    !

    Version 12.3

    service timestamps debug uptime

    service timestamps log uptime

    no service password-encryption

    !

    hostname DSW1

    ip cef

    !

    ip subnet-zero

    !

    no ip domain-lookup

    spanning-tree mode pvst

    spanning-tree extend system-id

    !

    interface Port-channel1

    switchport trunk encapsulation dot1q

    switchport mode trunk

    !

    interface FastEthernet0/1

    switchport trunk encapsulation dot1q

    switchport mode trunk

    channel-protocol lacp

    channel-group 1 mode passive

    !

    interface FastEthernet0/2

    switchport trunk encapsulation dot1q

    switchport mode trunk

    channel-protocol lacp

    channel-group 1 mode passive

    !

    interface FastEthernet0/3

    switchport trunk encapsulation dot1q

    switchport mode trunk

    channel-protocol lacp

    channel-group 1 mode passive

    !

    interface FastEthernet0/4

    switchport trunk encapsulation dot1q

    switchport mode trunk

    channel-protocol lacp

    channel-group 1 mode passive

    !

    interface FastEthernet0/5

    switchport trunk encapsulation dot1q

    switchport mode trunk

    channel-protocol lacp

    channel-group 1 mode passive

    !

    interface FastEthernet0/6

    switchport trunk encapsulation dot1q

    switchport mode trunk

    channel-protocol lacp

    channel-group 1 mode passive

    !

    interface FastEthernet0/7

    switchport trunk encapsulation dot1q

    switchport mode trunk

    channel-protocol lacp

    channel-group 1 mode passive

    !

    interface FastEthernet0/8

    switchport trunk encapsulation dot1q

    switchport mode trunk

    channel-protocol lacp

    channel-group 1 mode passive

    !

    interface FastEthernet0/9

    switchport trunk encapsulation dot1q

    switchport mode trunk

    channel-protocol lacp

    channel-group 1 mode passive

    !

    interface FastEthernet0/10

    switchport trunk encapsulation dot1q

    switchport mode trunk

    channel-protocol lacp

    channel-group 1 mode passive

    !

    interface FastEthernet0/11

    !

    interface FastEthernet0/12

    !

    interface GigabitEthernet0/1

    switchport trunk encapsulation dot1q

    switchport mode trunk

    !

    interface GigabitEthernet0/2

    switchport trunk encapsulation dot1q

    switchport mode trunk

    !

    interface Vlan 1

    no ip address

    no ip route-cache

    !

    ip classless

    no ip http server

    !

    line con 0

    line aux 0

    line vty 0 4

    !

    no scheduler allocate

    end


Recommended