Onpage optimierung mit dem seo screaming frog

  • View
    4.974

  • Download
    4

Embed Size (px)

DESCRIPTION

Campixx 2013 - Onpage Optimierung mit dem SEO Screaming Frog von Stephan Walcher.

Transcript

  • 1. Stephan Walcher Senior SEO Consultant Seit 2006 im Bereich SEO aktiv SEO in Sdtirol mit Schwerpunkt Tourismus Ex-Bing & MSN Seit 2011 bei Catbird Seat / Head of Consulting Links: Blog http://www.prometeo.de Twitter http://twitter.com/stephanw Weitere Profile http://prm.im & www.google.de 1
  • 2. SEO Onpage Analyse mit dem SEO Screaming Frog und natrlich Excel 2
  • 3. SEO Screaming FrogMehr als nur ein einfacher Crawler Fr Windows, Mac oder Ubuntu verfgbar Basiert auf Java Gratisversion erlaubt max. 500 URLs zu crawlen - 99 ohne VAT Beliebig viele Crawls User-Agent frei definierbar Liefert zahlreiche Fehlerlisten 30X redirects 404/50X Duplicate Pages (Hash Wert) Meta Description (nicht vorhanden, zu lang, usw) H1/H2 (nicht vorhanden, zu lange, multiple) Canonicals (nicht vorhanden) Meta Robots (noindex, nofollow usw.) In- und Outlinks Anchor Text Usw. 3
  • 4. Onpage Analyse - Prozess Probe Vollstndiger Crawl Scan Setup Daten SessionIDs Analyse Tracking Facebook 4
  • 5. SEO Screaming Frog - bersicht 5
  • 6. SEO Screaming Frog Status Codes 6
  • 7. SEO Screaming Frog Listen Export 7
  • 8. SEO Screaming Frog - Title 8
  • 9. 9
  • 10. SEO Screaming Frog H1 10
  • 11. SEO Screaming Frog Daten Import #1 11
  • 12. SEO Screaming Frog Daten Import #2 12
  • 13. Excel Daten erweitern - FormelnVerzeichnis aus der URL extrahieren*=WENNFEHLER(TEIL(S2;FINDEN("/";S2;LNGE("http://")+1);FINDEN("/";S2;FINDEN("/";S2;LNGE("http://")+1)+1)-FINDEN("/";S2;LNGE("http://")+1)+1);"") 13 * Markus Uhl - http://www.seodiot.de
  • 14. Excel Daten erweitern - FormelnCanonical berprfung=WENN([@[Canonical 1]]="";"kein Canonical";WENN(A3=X3;"Canonical auf sich selbst(unique)";"Canonical auf andere Seite (DC)")) 14
  • 15. Excel Daten erweitern - FormelnCross Domain Canonical?=WENN(S2=" ";;UrlProperty(S2; "host")) Bentigt: Excel SEO Tools - http://nielsbosma.se/projects/seotools/ 15
  • 16. Excel Daten erweitern - FormelnGoogle Index Checker (kann eine Weile dauern)=WENN(ISTFEHLER(IDENTISCH(TEIL(XPathOnUrl("http://www.google.de/search?gcx=c&sourceid=chrome&ie=UTF-8&q="&("site:"&(A8))&"&pws=0";"//li[@class=g]//h3[@class=r]//a";"href");8;LNGE(A8));A8));" ";"Indexiert") Bentigt: Excel SEO Tools - http://nielsbosma.se/projects/seotools/ 16
  • 17. Excel Daten erweitern Data MergingBacklinks=WENNFEHLER(SVERWEIS(A2;Backlinks!A:F;2;FALSCH);"") 17
  • 18. Excel Daten erweitern Data MergingBacklinks 18
  • 19. Excel Daten erweitern Data MergingBacklinks Extra Reiter 19
  • 20. Excel Daten erweitern Data MergingBacklinks Suchkriterium: Was suchen wir? Matrix: In welchem Bereich suchen wir? Spaltenindex: In welcher Spalte steht unser Output? Bereich_Verweis: immer auf falsch 20
  • 21. Excel Daten erweitern Data MergingBacklink Daten importieren=WENNFEHLER(SVERWEIS(A2;Backlinks!A:F;2;FALSCH);"") 21
  • 22. Excel Daten erweitern Data MergingTop Keyword identifizieren 22
  • 23. Excel Daten erweitern Data MergingURL Keyword Kombination aus Google Analytics exportieren 23
  • 24. Excel Daten erweitern Data Merging50.000 Datenstze exportieren URL ndern CSV Expotieren 24
  • 25. Excel Daten erweitern Data MergingIn einen neuen Reiter importieren & sortieren 25
  • 26. Excel Daten erweitern Data MergingTopKeywords pro URL=WENNFEHLER(SVERWEIS(A2;GA-Data!A:C;3;FALSCH);"") 26
  • 27. Excel Daten erweitern Data MergingTopKeywords pro URL=WENN(LNGE(GLTTEN(K6))=0;0;LNGE(GLTTEN(K6))-LNGE(WECHSELN(K6;"";""))+1) 27
  • 28. Excel Daten erweitern Data MergingSocial Signals, PageRank, usw. dank Link Research Tool 28
  • 29. Excel Daten erweitern Data MergingSocial Signals, PageRank, usw. dank Link Research Tool 29
  • 30. Excel Daten