85
Basic Networking: Basic Networking: NETWORKING TOPOLOGY Network topology is defined as the physical interconnection of the various elements (links, nodes, etc.) of a computer network. Network Topologies can be physical or logical. Physical Topology means the physical design of a network including the devices, location and cable installation. Logical topology refers to the fact that how data actually transfers in a network as opposed to its design. Network topologies are categorized into the following basic types: bus ring star tree / hybrid mesh Bus Topology Bus networks (not to be confused with the system bus of a computer) use a common backbone to connect all devices. A single cable, the backbone functions as a shared communication medium that devices attach or tap into with an interface connector. A device wanting to communicate with another device on the network sends a broadcast message onto the wire that all other devices see, but only the intended recipient actually accepts and processes the message. Ethernet bus topologies are relatively easy to install and don't require much cabling compared to the alternatives. 10Base-2 ("ThinNet") and 10Base-5 ("ThickNet") both were popular Ethernet

CCNA 640-802

Embed Size (px)

DESCRIPTION

ccna

Citation preview

Page 1: CCNA 640-802

Basic Networking:Basic Networking:

NETWORKING TOPOLOGY

Network topology is defined as the physical interconnection of the various elements (links, nodes, etc.) of a computer network. Network Topologies can be physical or logical. Physical Topology means the physical design of a network including the devices, location and cable installation.  Logical topology refers to the fact that how data actually transfers in a network as opposed to its design.

Network topologies are categorized into the following basic types:

bus ring star tree / hybrid mesh

Bus Topology

Bus networks (not to be confused with the system bus of a computer) use a common backbone to connect all devices. A single cable, the backbone functions as a shared communication medium that devices attach or tap into with an interface connector. A device wanting to communicate with another device on the network sends a broadcast message onto the wire that all other devices see, but only the intended recipient actually accepts and processes the message.

Ethernet bus topologies are relatively easy to install and don't require much cabling compared to the alternatives. 10Base-2 ("ThinNet") and 10Base-5 ("ThickNet") both were popular Ethernet cabling options many years ago for bus topologies. However, bus networks work best with a limited number of devices. If more than a few dozen computers are added to a network bus, performance problems will likely result. In addition, if the backbone cable fails, the entire network effectively becomes unusable.

Page 2: CCNA 640-802

Ring Topology

In a ring network, every device has exactly two neighbors for communication purposes. All messages travel through a ring in the same direction (either "clockwise" or "counterclockwise"). A failure in any cable or device breaks the loop and can take down the entire network.To implement a ring network, one typically uses FDDI, SONET, or Token Ring technology. 

Star Topology

Many home networks use the star topology. A star network features a central connection point called a "hub" that may be a hub, switch or router. Devices typically connect to the hub with Unshielded Twisted Pair (UTP) Ethernet.

Compared to the bus topology, a star network generally requires more cable, but a failure in any star network cable will only take down one computer's network access and not the entire LAN. (If the hub fails, however, the entire network also fails.)

Page 3: CCNA 640-802

Hybrid / Tree Topology

Tree topologies integrate multiple star topologies together onto a bus. In its simplest form, only hub devices connect directly to the tree bus, and each hub functions as the "root" of a tree of devices. This bus/star hybrid approach supports future expandability of the network much better than a bus (limited in the number of devices due to the broadcast traffic it generates) or a star (limited by the number of hub connection points) alone.

Mesh Topology

Mesh topologies involve the concept of routes. Unlike each of the previous topologies, messages sent on a mesh network can take any of several possible paths from source to destination. (Recall that even in a ring, although two cable paths exist, messages can only travel in one direction.) Some WANs, most notably the Internet, employ mesh routing.

A mesh network in which every device connects to every other is called a full mesh. As shown in the illustration below, partial mesh networks also exist in which some devices connect only indirectly to others.

Page 4: CCNA 640-802

NETWORKING TERMS:

LAN Local Area Network

This is used in a small area, an office or organization

The computers can be connected to each other and other devices, printer or a modem

The rate at which the data is transmitted is very fast

MAN Metropolitan Area Network

This is used in a large geographical area, town or city

Enables high speed connections using fiber optic

WAN Wide Area Network

This is used in a larger area than MAN, countries or cities

Enables high speed connections using public networks, telephone lines, satellites, or leased lines

Page 5: CCNA 640-802

MODES OF TRANSMISSION

Simplex Mode

Only one device can transmit the data, whereas the other can only receive the data

Half Duplex Mode

Both devices can transmit and receive the data, but not simultaneously

Full Duplex Mode

Both the devices can send and receive the data simultaneously

Page 6: CCNA 640-802

Difference between Half Duplex and Full Duplex

HALF DUPLEX FULL DUPLEXOne wire is used to connect the networks and transmit the data

Two wires are used to connect the networks and transmit the data

Chances of collision if client and server transmit data simultaneously

There are no chances of collision

It uses Carrier Sense Multiple Access with Collision Detection (CSMA/CD) protocol

CSMA/CD not required hence the data transmission rate is 100 percent

CHAPTER 1:

INTERNETWORKINGINTERNETWORKING

Def: When routers connect two or more networks together and use logical addressing (IP addresses), this is called an Interwork.

Devices:

1) HUB : Hub doesn’t segment a network; they just connect network segments together.

2) SWITCH : Switches only switch frames from one port to another within the switched network. It segment the each network to create a separate collision domain. But, the fact is that this network is still one broadcast domain.Switches break up collision domain.

3) BRIDGE : It is similar to switch.

4) ROUTER: Routers by default break up a broadcast domain. Meaning that the set of all devices on a network segment that hear all the broadcasts sent on that segment.

ADVANTAGES OF USING ROUTER:There are two advantages of using routers in the network: They don’t forward broadcasts by default They can filter the network based on layer 3 (Network Layer) information (eg. IP

Address)

FUNCTIONS OF ROUTERS:

Packet switching

Page 7: CCNA 640-802

Packet filtering Internetwork communication Path selection

INTERNETWORKING MODELS

When networks first come into being, computers could typically communicate only with computers from the same manufacturer. For example, companies ran either a complete DECnet (now Compaq) solution or an IBM solution – not both together.

In the late 1970s, the Open System Interconnection (OSI) reference model was created by the International Organization for Standardization (ISO) to break this barrier.

The OSI model was meant to help vendors create interoperable network devices and software in the form of protocols so that different vendor networks could work with each other.

The OSI model is the primary architectural model for networks. It describes how data and network information are communicated from an application on one computer through the network media to an application on another computer. The OSI reference model breaks this approach into layers.

ADVANTAGES OF REFERENCE MODEL

It divides the network communication process into smaller and simpler components, thus aiding component development, design and troubleshooting.

It allows multiple-vendor development through standardization of network components.

It encourages industry standardization by defining what functions occur at each layer of the model.

It allows various types of network hardware and software to communicate. It prevents changes in one layer from affecting other layers, so it does no hamper

development.

THE OSI REFERENCE MODEL

The OSI isn’t a physical model, though. Rather, it’s a set of guidelines that application developers can use to create and implement application will communicate with each other and with users. It also provides a framework fir creating and implementing networking standards, devices, and internetworking scheme.

Page 8: CCNA 640-802

We use the concept of layers in our daily life. As an example, let us consider two friends who communicate through postal mail. The process of sending a letter to a friend would be complex if there were no services available from the post office.

THE OSI MODEL

Established in 1947, the International Standards Organization (ISO) is a multinational body dedicated to worldwide agreement on international standards. An ISO standard that covers all aspects of network communications is the Open Systems Interconnection (OSI) model. It was first introduced in the late 1970s.

Seven layers of the OSI model

Page 9: CCNA 640-802

PHYSICAL LAYER :

The physical layer is the first or bottommost of OSI reference model. It is responsible for physical mechanism of network connection.

The type of interface card used on networking devices. The type of cable used for connecting devices The connectors used on each end for the cable Topology used

In physical layer the data is in the form of bits & bytes i.e (o’s & 1’s)

Physical layer devices are : HUB, cable, connector etc

DATA LINK LAYER:

This layer represented physical of hardware devices. It also defines how a device access the media that is connected as well defining the frame media type.

It is responsible for taking bits from physical layer and reassembling into original data link frame. It is also responsible to perform error detection but not correction.

Data link layer devices are: Switch and Bridge

Data link layer is divided into two sub layers:

The Logical Link Control (LLC) 802.2 – This layer is the upper sub-layer of the Data Link Layer. It provides multiplexing and flow control mechanisms that make it possible for several network protocols (IP, IPX) to coexist within a multipoint network and to be transported over the

Page 10: CCNA 640-802

same network media.. It attaches header which tells the data link layer what to do with the packet when the frame is received. It also provide flow control and sequence of bits.

The Media Access Control (MAC) 802.3 – This layer is the lower sub-layer of the Data Link Layer. It defines how packets are placed on the media. Physical addressing is defined here, as well as logical topologies. Line discipline, error notification (not correction), ordered delivery of frames and optional flow control can be used at this sublayer.

NETWORK LAYER:

The Network layer provides quite few actions. First it provide a logical topology of network using logical topology or layer three addressing. These addresses are used to group machines address together. Then it performs routing (collection of data from one end to other).

Protocols used in this layer are: IP (windows), IPX (Novell) and AppleTalk (For Macintosh)

Network layer device: Router

TRANSPORT LAYER:

Transport layer is responsible for actual mechanism of collection where it can provide reliable & unreliable delivery of data. For reliable connection transport layer is responsible for error detection & correction.

Protocol used in this layers are:

TCP (Transmission Control Protocol) & UDP (User Datagram Protocol)

TCP UDPIt is reliable It is unreliableAcknowledgement is received No acknowledgementWired media is used Wireless media us used

SESSION LAYER:

It is responsible for initializing the setup & tear down of the connection. In order to perform this function the session layer must determine weather data sent to local computer or to remote network device.

Page 11: CCNA 640-802

PRESENTATION LAYER:

This layer provides how information is presented to a user. This layer defines how various forms of text, graphics, video & audio information is represented to a user. Text is represented in two forms:

ASCII – American Standard Code for Information Interchange (ISO standard)

EBCDI – Extended Binary Code for Decimal Interchange (IBM prop.)

APPLICATION LAYER:

It provides the interface that a person used to interact with the application. The interface can be a command line or graphical based.

The IOS of Cisco routers and switches have a command line interface where as a web browser uses graphical interface.

E.g.: Telnet, HTTP, SMTP, TFTP

SUMMARY OF LAYERS:

Page 12: CCNA 640-802

HEXADECIMAL TO BINARY TO DECIMAL VALUES:

HEXADECIMAL BINARY DECIMAL0 0000 01 0001 12 0010 23 0011 34 0100 45 0101 56 0110 67 0111 78 1000 89 1001 9A 1010 10B 1011 11C 1100 12D 1101 13E 1110 14F 1111 15

CHAPTER 2

INTRODUCTION TO TCP/IPINTRODUCTION TO TCP/IP

TCP/IP and the DoD model

The Transmission Control Protocol / Internet Protocol (TCP/IP) suite was created by the Department of Defense (DoD) to ensure and preserve data integrity, as well as maintain communications in the event of catastrophic war. So it follows that if designed and implemented correctly, a TCP/IP network can be a truly dependable and resilient one.

The DoD model is basically a condensed version of the OSI model- its composed of four, instead of seven layers:

Process / Application layer Host to host layer Internet layer Network Access Layer

Page 13: CCNA 640-802

Process / Application Layer :

This layer functions same as upper three layers (Application, Presentation, and Session) of OSI reference model. The protocols used in this layer are:

FTP – File Transfer Protocol (Need authentication)

TFTP – Trivial File Transfer Protocol (No authentication)

SMTP - Simple Mail Transfer Protocol

DNS – Domain Name Service

BootP – Boot strap Protocol (For booting purpose of diskless machines)

DHCP – Dynamic Host Configuration Protocol (For assigning IP addresses automatically)

HOST-TO-HOST LAYER

This layer function same as Transfer layer of OSI reference model.

Protocols used in this layers are TCP & UDP.

INTERNET LAYER

This layer functions same as Network Layer of the OSI reference model

Protocols used in this layer are:

Page 14: CCNA 640-802

IP (Internet Protocol)

This protocol is aware of all interconnected networks. It looks each packet address. It creates a routing table. It decide which packet is to send through best route.

ICMP (Internet Control Messing Protocol)

It is used for messaging purpose

ARP (Address Resolution Protocol)

It resolves IP address to its associated MAC address

RARP (Reverse Address Resolution Protocol)

It resolves MAC address to its associated IP address

NETWORK ACCESS LAYER

The Network Access layer is different. The DOD did not develop any protocols for the Network Access layer, because they wanted to create a generic suite of protocols that would function on any vendor’s system. It was the responsibility of the individual vendors to create a set of protocols that would allow the Internet suite to work with their hardware. These vendors created protocols that would function at the Network Access layer. This is a main reason why the Internet protocol suite is used on so many different systems.

IP ADDRESSING

IP Address is 32 bit binary number, divided into 4 octate, for the identification of the machine in the network.

IP Terminology

Some important terms related to Internet Protocol

Bit – A bit is one digit, either 1 or 0

Byte – A byte is 8 bits

Octet – An octet is made up of 8 bits

Page 15: CCNA 640-802

Network address – This is the term used in routing to send packets to a remote network. For Ex: 10.0.0.0 172.16.0.0 192.168.10.0

Broadcast address: The address used by applications and hosts to send information to all nodes on a network is called the broadcast address. Examples include 255.255.255.255, which is the entire network, all the nodes: 172.16.255.255, which is all subnets and hosts on network 172.16.0.0: and 10.255.255.255, which broadcasts to all subnets and hosts on network 10.0.0.0

IP ADDRESS CLASSES

8 bits 8 bits 8 bits 8 bits

CLASS A NETWORK HOST HOST HOST

CLASS B NETWORK NETWORK HOST HOST

CLASS C NETWORK NETWORK NETWORK HOST

CLASS D MULTICAST

CLASS E RESEARCH

Network Address Range: Class A

The designers of the IP address scheme said that first bit of the first byte in a Class A network address must always be off, or 0. This means a Class A address must be between 0 and 127 in the first byte, inclusive.

Consider the following network address:

0xxxxxxx

If we turn the other 7 bits all off and then turn them all on, we’ll the Class A range of network address:

Page 16: CCNA 640-802

00000000 = 0

01111111 = 127

So, a Class A network is defined in the first octet between 0 and 127, and it can’t be less or more.( Yes, I know 0 and 127 are not valid in a Class A network. I’ll talk about reversed address in a minute.)

Network Address Range : Class B

In a class B network, the RFCs state that the first bit of the first byte must always be turned on but the second bit must always be turned off. If you turn the other 6 bits all off then all on, you will find the range for a Class B network :

10000000 = 128

10111111 = 191

As you san see, a Class B network is defined when the first byte is configured from 128 to 191.

Network Address range : Class C

For Class C network, the RFCs define the first 2 of the first octet as always turned on, but the third bit can never be on. Following the same process process as the previous classes, convert from binary to find the range. Here’s the range for a class C network :

1100000 = 192

1101111 = 223

So, if you see an IP address that strats at 192 and goes to 223, you’ll it is a Class C IP address.

Network Address range : Classes D and E

The address between 224 to 255 are reversed for Class D and E networks. Class D (224-239) is used for multicast address and Class E (240-255) for scientific purposes, but I,m not going into these types of addresses in this book ( and you don’t need to know them).

Network Addresses: special Purpose

Page 17: CCNA 640-802

Some IP addresses are reversed for special purpose s, so network administrators can’t ever assign these addresses to nodes

PRIVATE AND PUBLIC IP ADDRESS:

Public IP Address: These IP addresses are allocated to the ISP’s , from them you have to purchase it.

Private IP Address: These addresses can be used on a private network, but they’re not routable through the internet. That means, you can use these addresses within the organization and these are free.

PRIVATE IP ADDRESS RANGE

ADDRESS CLASS RANGECLASS A 10.0.0.0 TO 10.255.255.255.0CLASS B 172.16.0.0 TO 172.31.255.255CLASS C 192.168.0.0 TO 192.168.255.255

CHAPTER 3

SUBNETTING, VARIABLE LENGTH SUBNET MASKS (VLSM’s),SUBNETTING, VARIABLE LENGTH SUBNET MASKS (VLSM’s), and Troubleshooting TCP/IPand Troubleshooting TCP/IP

Subnetting: It is the process which allows you to take one larger network and break it into a bunch of smaller networks.

There are lots of reasons in favor of subnetting, including the following benefits:

Reduced network traffic Optimized network performance Simplified management Facilitated spanning of large geographical distance

Page 18: CCNA 640-802

Classful Subnet: It means that all the hosts (all nodes) in the network use the exact same subnet mask.

Eg: 255.0.0.0 255.255.0.0 255.255.255.0

Default Classful subnet mask:

Class A = 255.0.0.0

Class B = 255.255.0.0

Class C = 255.255.255.0

Classless Subnet: It means that each network segment can use a different subnet mask.

Eg: A single network with the combination of 255.255.255.128, 255.255.255.224, 255.255.255.240

IMPORTANT THINGS FOR SUBNETTING:

Power of 2

21=2, 22=4, 23=8, 24=16, 25=32, 2 6=64, 27=128, 28=256, 29=512, 210=1024,

211=2048, 212=4096, 213=8192, 214=16384

CLASSLESS INTER-DOMAIN ROUTING (CIDR)

This is the method that ISP’s (Internet Service Providers) use to allocate a number of addresses to a company, a home or a customer. They provide addresses in a certain block size, like you receive a block of addresses from an ISP, which look something like this: 192.168.10.32/28.

This is telling you what your subnet mask is. The slash notation (/) means how many bits are turned on (1s).

CIDR Values

Page 19: CCNA 640-802

CIDR Value Subnet Mask/8 255.0.0.0/9 255.128.0.0/10 255.192.0.0/11 255.224.0.0/12 255.240.0.0/13 255.248.0.0/14 255.252.0.0/15 255.254.0.0/16 255.255.0.0/17 255.255.128.0/18 255.255.192.0/19 255.255.224.0/20 255.255.240.0/21 255.255.248.0/22 255.255.252.0/23 255.255.254.0/24 255.255.255.0/25 255.255.255.128/26 255.255.255.192/27 255.255.255.224/28 255.255.255.240/29 255.255.255.248/30 255.255.255.252

Values of each bit in an octet:

Binary Decimal CIDR

00000000 0 /24

10000000 128 /25

11000000 192 /26

11100000 224 /27

11110000 240 /28

11111000 248 /29

11111100 252 /30

(We can’t us /31 and /32 because we must have at least 2 host bits for assigning IP addresses to hosts)

For subnetting do following things:

Page 20: CCNA 640-802

1)Convert CIDR Value

Ex: /25 = 255.255.255.128

2) Block size= Subtract the last value from 256.

Ex: /25=255.255.255.128, block size = 256-128=128

3) Number of networks= 2n (where n=no.of ON bits)

4)Number of hosts=2n-1 (where n=no.of OFF bits)

Example: If a company has assigned you the IP address

Say: 192.168.10.0/26

Solution:

192.168.10.0 is your network address, which you have to use for the host

/26 is the CIDR value

1) Convert CIDR value into to subnet

/26 = 255.255.255.192

2) Block size 256-192 = 64

3) Number of Network (ON bits)

22 = 4

4) Number of Host (OFF bits)

26 -2 = 62

Our block size is 64, means start from 0 with each gap of 64(blocksize) upto the last no.=192

0 64 128 192 Network Address1 65 129 193 1st Host

62 126 190 254 Last host63 127 129 255 Broadcast

So, there are 4 networks: 0,64,128,192And the IP address assigned to host using the given network address are:In 0’s network, it will be from

Page 21: CCNA 640-802

192.168.10.1 to 192.168.10.62255.255.255.192 255.255.255.192

In 64’s network, it will be from192.168.10.65 to 192.168.10.126255.255.255.192 255.255.255.192

In 128’s network, it will be from192.168.10.129 to 192.168.10.190255.255.255.192 255.255.255.192

In 192’s network, it will be from192.168.10.93 to 192.168.10.254255.255.255.192 255.255.255.192

Check this: there are 4 networks with 64 hosts each.

Example of. /27

1) Covert CIDR value in Sul net /27= 255.255.255.224

2) Block size 256 - 224 = 32

3) Number of network 23 = 8

4) Number of Host25 = 8

0 32 64 96 128 160 192 224 Broadcast1 33 65 97 129 161 193 225 1st Host

30 62 94 126 158 190 222 224 Last Host31 63 95 127 159 191 223 255 Broadcast

SUBNETTING CLASS B:This is the same as subnetting with class C, except we start in the third octet here.

Example: If a company has assigned you the IP address

Say: 172.16.0.0/18

Solution:

Page 22: CCNA 640-802

/18 is the CIDR value

1) Convert CIDR value into to subnet

/18 = 255.255.192.0

2) Block size 256-192 = 64

3) Number of Network (ON bits)

22 = 4

4) Number of Host (OFF bits)

214 -2 = 16382

Our block size is 64, means start from 0 with each gap of 64(blocksize) upto the last no.=192

0.0 64.0 128.0 192.0 Network Address0.1 64.1 128.1 192.1 1st Host

63.254 127.254 191.254 255.254 Last host63.255 127.255 191.255 255.255 Broadcast

So, there are 4 networks: 0.0, 64.0, 128.0, and 192.0And the IP address assigned to host using the given network address are:In 0’s network, it will be from 172.16.0.1 to 172.16.63.254255.255.192.0 255.255.192.0

In 64’s network, it will be from172.16.64.1 to 172.16.127.254255.255.192.0 255.255.192.0

In 128’s network, it will be from172.16.128.1 to 172.16.191.254255.255.192.0 255.255.192.0In 192’s network, it will be from172.16.192.1 to 172.16.255.254255.255.192.0 255.255.192.0

Check this: there are 4 networks with 16382 hosts each.

Page 23: CCNA 640-802

CLASS A SUBNETTING:This is the same as subnetting with class C or B, except we start in the Second octet here.

VARIABLE LENGTH SUBNET MASK (VLSM)In VLSM, there is a way to take on network and create many networks using subnet masks of different lengths on different types of network designs.Here comes the concept of class full and classless networking.

Using VLSM

Page 24: CCNA 640-802

Troubleshooting IP addressing

In the above scenario, if your pc’s ip address is 192.168.10.10For troubleshooting, do the following things:

1)On your PC, start- run- cmd- ping 127.0.0.1

Page 25: CCNA 640-802

This is the diagnostic, or loopback address to check your IP stack

2)On your PC, start- run- cmd- ping 192.168.10.10 This is the diagnostic, of your LAN card (NIC-Network Interface Card)

3)On your PC, start- run- cmd- ping 192.168.10.1 This is the diagnostic, of your gateway (Interface of router, where LAN connected)

4)On your PC, start- run- cmd- ping 192.168.20.1This is the diagnostic, of your WAN port (WAN link)

There are some basic commands that you can use to help troubleshoot your network from both a PC and a Cisco router.

Packet InterNet Groper (ping) Uses the ICMP echo request and replies to test if a node IP stack is initialized and alive on the network.Traceroute Displays the list of routers on a path to a network destination by using TTL time-outs and ICMP error messages. This command will not work from a DOS prompt.Tracert Same command as traceroute, but it’s a Microsoft Windows command and will not work on a Cisco router.Arp –a Displays IP-to-MAC address mappings on a Windows PC.Show ip arp Same command as arp –a, but displays the ARP table on a Cisco router. Ipconfig /all Used only from a DOS prompt, shows you the PC network configuration.

CHAPTER 4

Cisco’s Interworking Operating System (IOS) and Security DeviceCisco’s Interworking Operating System (IOS) and Security Device Manager (SDM)Manager (SDM)

IOS – The Internetworking Operating System, runs Cisco routers as well as switches, and it allows to configure the devices as well.

About Cisco IOSThe Cisco IOS is a proprietary kernel that provides routing,switching,interworking and telecommunications features. The first IOS was written by William Yeager in 1986, and it enabled networked applications.The IOS software is responsible for:

Carring network protocols and functions Connecting high-speed traffic between devices Adding security to control access and stop unauthorized network use Providing scalability for ease of network growth and redundancy

Page 26: CCNA 640-802

You can access the Cisco IOS through the console port of router, from a modem into the auxiliary port, or even through Telnet.

CONNECTING TO A CISCO ROUTER

There are different ways to do this, but most often, the first place you would connect to is the console port. The console port is usually an RJ-45 connection located at the back of the router.

Serial0/1 Serial0/0 (For Router to router)

FastEthernet 0/0 Auxiliary (For LAN connection) (to connect with modem)

Console (to PC for Configuration of router)

ROUTER COMPONENTS

A Cisco router does not contain disk storage mechanisms such as hard disks. Therefore, the router requires certain hardware and firmware components for proper functioning. These components allow the router to enter the boot up process, load its operating system, and configuration files. A router has six different components.

Processor

Cisco router has a processor (CPU) that executes the IOS commands using the other router components. Cisco routers use two types of processors such as Motorola 68030 and Orion/R4600. The Cisco IOS software makes routing decisions and maintains routing tables using the processor.

ROM

The Read Only Memory (ROM) is a non-volatile memory storage device. It does not lose its contents when the power supply is turned off. The components of the ROM decide the boot process of the router.

Page 27: CCNA 640-802

The ROM consists of the following components:

i) POSTThe Power-On-Self-Test component provides a series of diagnostic tests for the router. These tests start when the router is switched on. The POST is a series of 14 tests that run in the reverse numerical order. The functionality of the router depends on the result of the tests.

ii) Bootstrap ProgramThe Bootstrap Program is a ROM Monitor component that allows you to initialize the processor hardware when the router boots. This component boots the operating system software after initializing the processor hardware.It loads the IOS image for the router, with the help of a configuration register.

iii) Mini-IOSThis component is not present in every router. It provides an alternate file for the router boot up, if the existing image file is unavailable. It provides a minimized version of the IOS image file consisting of only the IP code.

iv) ROM MonitorIt is a program stored in the ROM which is used to debug user programs. The ROM Monitor also allows manufacturing, testing and troubleshooting of ROM.

RAM

The function of Random Access Memory in router is similar to memory in computer. It is a volatile storage medium that loses data when the device is switched off. It consists of the active IOS image that is loaded when the router boots. It temporarily stores the active configuration files, routing tables and information in the input and output buffers of the router interface.

Flash

The flash memory in a router is a non-volatile storage medium. It is basically EEPROM. The flash memory contains IOS images using which router boots.

NVRAM

Non-Volatile RAM is a type of random access memory that stores configuration files for the router. The startup file and the configuration register for the router are present in the NVRAM. The configuration register specifies the boot up options for the router.Configuration Register

Page 28: CCNA 640-802

It is used to hold the configuration of the router or configuration files of a router. The typical value of configuration register is hexadecimal 0x2102. Using this value the router loads IOS from the flash memory and configuration from the NVRAM

CONNECTING ROUTER TO PC:

Connect router to PC using console cable. Console port (RJ-45) on routers Console port and other side with serial connector to PC’s com port.

On windows, click onStart -> Program -> Accessories -> Communications -> HyperTerminal

Give name : ex RouterA and select Icon, press OK

Page 29: CCNA 640-802

Select COM1

Select Restore Defaults, then you will be in routers console.

Page 30: CCNA 640-802

When you first start the router, it will open the setup, which is the wizard mode to configure.

In the first line, if you choose the option n, then it will open the CLI (Command Line Interface)CLI – Command Line Interface

Symbol Modes of Router Working

> User EXEC mode Limited to basic monitoring commands

# Privileged mode Provide access to all other router commands

(Config)# Global config mode Commands that affect the entire system

(Config-if)# Interface mode Commands that affect the interfaces

ROUTER CONFIGURATION:

Router> (this is user mode)

Here type enable to go to next (privilege) mode

Router# (this is privilege mode)

Here type config t to go to next (configuration) mode

Router(config)# This is the config or global configuration mode

Page 31: CCNA 640-802

All the configuration of the routers are done here

Setting Hostname

Setting Banner

Setting Passwords

User mode password

Privilege mode password

There are two types of passwords used here, you can apply any one or both. Password of both should not be similar.

Here, enable password keep the password plain while enable secret encrypts the password.

IF you want to encrypt enable password, given command

RouterA(config)#service password-encryption

Page 32: CCNA 640-802

Telnet password

Auxillary password

RouterA (config) # line aux 0

RouterA (config) # password auxillary

RouterA (config) # login

To RESET the password

In 2500 series

Boot the router, press Ctrl+Break to interrupt the router boot sequence. The router then boots into ROM monitor mode, the rommon> prompt appears.

Type o.

Type 0/r 0x2142

Type I to reload the router

In 2600 series

Boot the router, press Ctrl+Break to interrupt the router boot sequence. The router then boots into ROM monitor mode, the rommon> prompt appears.

Type confreg 0x2142

Type reset

Page 33: CCNA 640-802

CONFIGURATION OF INTERFACE WITH IP ADDRESS

On RouterA we are configuring the ip address on FastEthernet0/0 and Serial0/0

While configuration of these interfaces, you might noticed that

Page 34: CCNA 640-802

In fastethernet0/0 there is only no shut while

In Serial0/0, there are two things mentioned i.e clock rate 64000 and bandwidth 64.

Explanation:

Consider the following three routers

Routers A and Router C will not pass the packets from their other end.

Router B will pass packet for both end. That is, one end to Router A and other end to Router B

This means Router A and Router C are end routers, that terminate the connection and hence, these are DTE (Data Termination Equipment) in which bandwidth is given, while on Router B the packets are switched from Router A to Router C and vice-versa. It means that it is clocking from one to other. This is called DCE (Data Communication Equipment) where clock rate is given.

To check DTE or DCE

Descriptions:

The description command is helpful to administrator, to keep the track or details about the particular.

RouterA(config)#int fa0/0

RouterA(config)#description Connection to LAN of network 192.168.10.0

Saving & Viewing Configuration

Page 35: CCNA 640-802

While you configuring a router, the setting is temporary stored in DRAM (known as running-config), if router is switched off the setting will be deleted. To store the setting so that when the next time when the router start, you could get the setting, means it should be stored in NVRAM (known as startup-config), you have to do the following

RouterA# copy run start

(That will copy the running-config to start-up config)

To View

RouterA# show run

CHAPTER 5

Managing a Cisco Internetwork

Backing up the Cisco IOS

The Cisco router contains the IOS which is inbuild loaded by the vendon in flash.

To view the IOS, the command in routers config mode are:

config# show flash and/or config# show version

There you can see a file name like: c2600-adventerprisek9-mz.124-19.bin

The IOS file is having the extension .bin

You have to take a back up of this file, so in case of any problem you can reload it.

To backup the IOS:

First you need a TFTP server (This is an application which you get free on internet.). After installing a TFTP on your PC it will work as TFTP server and automatically take the IP address of your PC. Suppose your PC’s IP address is 192.168.10.10, the same address will be of TFTP server. Run the TFTP server application.

Go to routers console

Router#copy flash tftp

Source filename []? C2600-adventerprisek9-mz.124-19.bin

Address or name of remote host []? 192.168.10.10

Destination filename [C2600-adventerprisek9-mz.124-19.bin]?[Enter]

! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! !

Page 36: CCNA 640-802

Cisco IOS File system commands:

dir same as the command in windows, this command lets you view files in a directory

copy This command is used to upgrade,restore or back up an IOS.

more same as Unix, this will give you a text file and let you look at it on a card.

Show file This command is used to see specified file or file system, but it is not used in lot.

delete This command is used to delete the stuff.

Erase/format Use these command with care.This command will erase the file system or IOS.

Cd/pwd Same as with Unix or DOS, cd is the command uou use to change directories. Use the pwd command to print (show) the working directory.

Mkdir/rmdir This command is used to create and delete directories. The mkdir is for creation and rmdir for deletion.

Using Cisco Discovery Protocol (CDP)

CDP is a proprietary protocol designed by cisco to help administrators collect information about both locally attached and remote devices. By using CDP, you can gather hardware and protocol information about neighbor devices, which is useful info for troubleshooting and documenting the network.

Getting CDP timers and Holdtime Information

The show cdp command gives you information about two CDP global parameters that can be configured on Cisco devices:

CDP timer is how often CDP packets are transmitted out all active interfaces.

CDP holdtime is the amount of time that the device will hold packets received from neighbor devices.

Gathering Neighbor Information

The show cdp neighbor commond ( sh cdp nei for short ) delivers information about directly connected devices.

Router#sh cdp neighbors

Output of the show cdp neighbor Commond

Page 37: CCNA 640-802

Field Description

Device ID The hostname of the device directly connected.

Local Interface The port or interface on which you are receiving the CDP packet.

Holdtime The amount of time the router will hold the information before discarding

It if no more CDP packets are received.

Capability The capability of the neighbor, such as the router, switch, or repeater.

The capability codes are listed at the top of the command output.

Platform The type of Cisco device directly connected. In the previous output, a

Cisco 2500 router and Cisco 1900 switch are attached directly to

The 2509 router. The 2509 only sees the 1900 switch and the 2500

Router connected through its serial 0 interface.

Port ID The neighbor device’s port or interface on which the CDP packets are

Multicast.

Router#sh cdp neighbors detail

This command can be run on both routers and switches, and it displays detailed information about each device connected to the device you’re running the command on.

Remember that you can see the IP address of only directly connected devices.

Router#sh cdp-entry *

The show cdp entry * command displays the same information as the show cdp neighbors details command.

There isn’t any difference between the show cdp neighbors details and show cdp entry * commands. However, the sh cdp entry * command has two options that the show cdp neighbors details command does not:

Gathering Interface Traffic Information

The show cdp traffic command displays information about interface traffic, including the number of CDP packets sent and received and the errors with CDP.

Gathering Port and Interface Information

Page 38: CCNA 640-802

The show cdp interface command gives you the CDP status on router interfaces or switch ports.

Using Telnet

Telnet, part of the TCP/IP protocol suite, is a virtual terminal protocol that allows you to make connections to remote devices, gather information, and run programs.

After your routers and switches are configured,you can use the Telnet program to reconfigure and/or check up on your routers and switches without using a console cable. You run the program by typing telnet from any command prompt ( DOS or Cisco ). You need to have VTY passwords set on the routers for his to work.

Telnet ting into Multiple Devices Simultaneously

If you telnet to a router or switch, you can end the connection by typing exit at any time. But what if you want to keep your connection to a remote device but still come back to your original router console? To do that, you can press the Ctrl+Shift+6 key combination, release it, and then press X.

Here’s an example of connecting to multiple devices from my Crop router console:

Checking Telnet Connections

Router#sh sessions

Conn Host Address Byte Idle Conn name

1 10.2.2.2 10.2.2.2 0 0 10.2.2.2

2 10.1.1.2 10.1.1.2 0 0 10.1.1.2

Checking Telnet Users

Router#sh users

Line User Host(s) Idle Location

0 con 0 10.1.1.2 00:00:01

10.2.2.2 00:01:06

Router#sh sessions

Page 39: CCNA 640-802

Conn Host Address Byte Idle Conn Name

1 10.1.1.2 10.1.1.2 0 0 10.1.1.2

2 10.2.2.2 10.2.2.2 0 0 10.2.2.2

Closing Telnet Sessions

Router#sh session

Conn Host Address Byte Idle Conn Name

2 10.2.2.2 10.2.2.2 0 0 10.2.2.2

Router#disconnect ?

< 0-0 > The number of an active network connection

qdm Disconnect QDM web-based clients

ssh Disconnect an active SSH connection

Router#disconnect 2

Closing connection to 10.2.2.2 [ confirm ] [ enter ]

SDM - Security Device Manager

SDM is a graphical user interface of the router. It is best used for advanced configurations like security, IPS,QoS, and NAT.

To install a SDM on your router, your router must have an IOS bundled with K9 security.

Ex: we have 2611 XM routers with IOS having k9 security.

Installation of SDM.

1. You need the application software SDMv24 or SDMv25 to be installed on PC & router.2. Your computer should be installed with latest version of java3. While installing SDM on router, you need the username and password, for that you have

to do the following configuration before installing SDM on your router.

Configuring router to run SDM

Page 40: CCNA 640-802

Follow the instructions below to configure a router to run SDM.

Step 1:

a. Connect to your router using Telnet, SSH or via console.

b. Enter the global configuration mode using the command:

Router>enable

Router#conf terminal

Router(config)#

Step 2 :

Enable the router's HTTP/HTTPS server, using the following Cisco IOS commands:  

Router(config)# ip http server

Router(config)# ip http secure-server

Router(config)# ip http authentication local

Note:- HTTPS is enabled only for crypto enabled IOS images.

Step 3:

Create a user with privilege level 15.

Router(config)# username <username> privilege 15 password 0 <password>

Note:- Replace <username> and <password> with the username and password that you want to configure.

Step 4:

Configure SSH and Telnet for local login and privilege level 15:

Router(config)# line vty 0 4

Router(config-line)# privilege level 15

Router(config-line)# login local

Router(config-line)# transport input telnet

Router(config-line)# transport input telnet ssh

Router(config-line)# exit

CHAPTER 6

Page 41: CCNA 640-802

IP Routing

Before going the know about the IP Routing, one should understand the difference between the routing protocol and routed protocol.

Routing Protocol: It is used by routers to dynamically find all the networks in the internetwork and to ensure that all routers have the same routing table. Basically, a routing protocol determines the path of a packet through an internetwork.

Examples of routing protocols are RIP,RIPv2, EIGRP and OSPF

Routed Protocol: It can be used to send user data (packets) through the established enterprise. Routed protocols are assigned to an interface and determine the method of packet delivery.

Examples of routed protocols are IPv4 and IPv6

The term routing is used for taking a packet from one device and sending it through the network to another device on a different network. Routers don’t really care about hosts- they only care about networks and the best path to each network.

TYPES OF ROUTING:

Static Routing:

The process of adding routes manually to the routing table is termed as static routing. The administrator is responsible for updating all changes by hand into all routers. This is feasible in small networks, but not in large.

Default Routing:

Default route is defined as the route that is not present in the network. Default routing is possible only with the routers have only one exit path from network (called stub networks). In default routing you have to assign only a gateway.

Dynamic Routing

In dynamic routing, a protocol on one router communicates with the same protocol running on neighbor routers. The routers then update each other about all the networks they know about and place this information into the routing table. If change occurs in the network, the dynamic routing protocol automatically inform all routers about the event.

Page 42: CCNA 640-802

We’ll see the practical examples of IP Routing, for that lab you need 3 routers each of them configured with hostname, IP addresses along with PC’s IP address.

STATIC ROUTING EXAMPLE

In static routing each router has to define the not connected networks with their respective interfaces.

Format: ip route <not connected n/w><subnetmask><gateway IP or port>

Router A:

RouterA(config)#ip route 192.168.30.0 255.255.255.0 192.168.20.2

RouterA(config)#ip route 192.168.40.0 255.255.255.0 192.168.20.2

RouterA(config)#ip route 192.168.50.0 255.255.255.0 192.168.20.2

Router B:

RouterB(config)#ip route 192.168.10.0 255.255.255.0 192.168.20.1

RouterB(config)#ip route 192.168.50.0 255.255.255.0 192.168.40.2

Page 43: CCNA 640-802

Router C:

RouterC(config)#ip route 192.168.10.0 255.255.255.0 192.168.40.1

RouterC(config)#ip route 192.168.20.0 255.255.255.0 192.168.40.1

RouterC(config)#ip route 192.168.30.0 255.255.255.0 192.168.40.1

Or instead of gateway IP you can also assign the port like

RouterC(config)#ip route 192.168.10.0 255.255.255.0 S0/1

RouterC(config)#ip route 192.168.20.0 255.255.255.0 S0/1

RouterC(config)#ip route 192.168.30.0 255.255.255.0 S0/1

DEFAULT ROUTING EXAMPLE

In default routing you can assign 0.0.0.0 as network and 0.0.0.0 as subnet, but only you have to assign the gateways

Format: ip route 0.0.0.0 0.0.0.0 <gateway IP or port>

Router A:

RouterA(config)#ip route 0.0.0.0 0.0.0.0 192.168.20.2

Router B:

RouterB(config)#ip route 0.0.0.0 0.0.0.0 192.168.20.1

RouterB(config)#ip route 0.0.0.0 0.0.0.0 192.168.40.2

Router C:

RouterC(config)#ip route 0.0.0.0 0.0.0.0 192.168.40.1

Or instead of gateway IP you can also assign the port like

RouterC(config)#ip route 0.0.0.0 0.0.0.0 S0/1

To check the IP route:

Router#show ip route

Page 44: CCNA 640-802

DYNAMIC ROUTING:

Two types of routing protocols are used in interworks: interior gateway protocols(IGPs) and exterior gateway protocols (EGPs).

IGPs are used to exchange routing information with routers in the same autonomous system(AS). An AS is a collection of networks under a common administrative domain, which basically means that all routers sharing the same routing table information are in the same AS.

EGPs are used to communicate between ASes. An example of an EGP in Border Gateway Protocol (BGP), which is beyond the scope of our syllabus.

AD Administrative Distances

The administrative distance (AD) is used to rate the trustworthiness of routing information received on a router from a neighbor router. An administrative distance is an integer from 0 to 255, where 0 is the most trusted and 255 means no traffic will be passed via this route.

Following table shows the default AD

Route Source Default ADConnected Interface 0Static route 1EIGRP 90IGRP 100OSPF 110RIP 120External EIGRP 170Unknown 255 (this route will never be used)

Routing Protocols

There are three classes of routing protocols

Distance vector: The distance vector protocols find the best path to a remote network by judging distance. Each time a packet goes through a router, that’s called a hop.

RIP and IGRP are distance vector routing protocols.

Link state In link-state protocols, also called shortest-path-first protocols, the routers each create three separate tables. One of these tables keeps track of directly attached neighbors, one determines the topology of the entire internetwork, and one is used as the routing table. Link state routers know more about the internetwork than any distance vector routing protocol.

OSPF is the link state routing protocol.

Page 45: CCNA 640-802

Hybrid Hybrid protocols use aspects of both distance vector and link state.

EIGRP is the hybrid routing protocol.

Routing loops

A routing loop is a common problem with various types of networks, particularly computer networks. They are formed when an error occurs in the operation of the routing algorithm, and as a result, in a group of nodes, the path to a particular destination forms a loop.

In the simplest version, a routing loop of size two, node A thinks that the path to some destination (call it C) is through its neighboring node, node B. At the same time, node B thinks that the path to C starts at node A.

Thus, whenever traffic for C arrives at either A or B, it will loop endlessly between A and B, unless some mechanism exists to prevent that behavior.

Network

How a routing loop can form

For example, in the network given below, node A is transmitting data to node C via node B. If the link between nodes B and C goes down and B has not yet informed node A about the breakage, node A transmits the data to node B assuming that the link A-B-C is operational and of lowest cost. Node B knows of the broken link and tries to reach node C via node A, thus sending the original data back to node A. Furthermore, node A receives the data that it originated back from node B and consults its routing table. Node A's routing table will say that it can reach node C via node B (because it still has not been informed of the break) thus sending its data back to node B creating an infinite loop.

Page 46: CCNA 640-802

Broken network

Example 2

Routing loops can occur because every router isn’t updated simultaneously, or even close to it. Here’s an example – let’s say that the interface to Network 5 in figure fails. All routers know about Network 5 from Router E. Router A, in its tables, has a path to Network 5 through Router B.

When Network 5 fails, Router E tells Router C. This causes Router C to stop routing to Net-work 5 through Router E. But routers A, B and D don’t know about Network 5 yet, so they keep sending out update information. Router c will eventually send out its update and cause B to stop routing to Network 5, but routers A and D are still not updated. To them, it appears that Network 5 is still available through Router B with a metric of 3.

Maximum Hop Count

The routing loop problem described is called counting to infinity, and it’s caused by gossip

( broadcasts ) and wrong information being communicated and propagated throughout the internetwork. Without some form of intervention, the hop count increases indefinitely each time a packet passes through a router.

Page 47: CCNA 640-802

Split Horizon

Another solution to the routing loop problem is called split horizon. This reduces incorrect routing information and routing overhead in a distance-vector network by enforcing the rule that routing information cannot be sent back in the direction from which it was received.

Route Poisoning

Another way to avoid problems caused by inconsistent updated stop network loops is route poisoning. For example, when Network 5 goes down, Router E initiates route poisoning by advertising Network 5 as 16, or unreachable ( sometimes reffered to as infinite.)

Holddowns

A holddown prevents regular update messages from reinstating a route that is going up and down ( called flapping ). Typically, this happens on a serial link that’s losing connectivity and then coming back up. If there wasn’t way to stabilize this, the network would converge and that one flapping interface could bring the entire network down.

Distance Vector Routing Protocol

RIP: Routing Information Protocol

Routing Information Protocol is a true distance-vector routing protocol. RIP sends the complete routing table out to all active interfaces every 30 seconds. RIP only uses hop count to determine the best way to a remote network, but it has a maximum allowable hop count of 15 by default, meaning that 16 is deemed unreachable. RIP works well in small networks, but it’s inefficient on large networks with slow WAN links or on networks with a large number of routers installed.

RIP Timers

Route update timer 30 seconds

Route invalid timer 180 seconds

Route flush timer 240 seconds

Page 48: CCNA 640-802

Configuring RIP routing

While configuring Dynamic routing, you have to consider only connected networks.

Router A

RouterA(config)#router rip

RouterA(config)#network 192.168.10.0

RouterA(config)#network 192.168.20.0

Router B

RouterB(config)#router rip

RouterB(config)#network 192.168.20.0

RouterB(config)#network 192.168.30.0

RouterB(config)#network 192.168.40.0

Page 49: CCNA 640-802

Router C

RouterC(config)#router rip

RouterC(config)#network 192.168.40.0

RouterC(config)#network 192.168.50.0

Related commands of RIP

To check the rip configuration:

Router#show ip route

To debug

Router#debug ip rip

To undebug

Router#undebug all

RIP has two versions RIPv1 and RIPv2, by default version 1 is used, for using version 2 the configuration is

Router(config)#router rip

Router(config)#version 2

DIFFERENCE BETWEEN RIPv1 AND RIPv2

RIP v1 RIP v2Distance vector Distance VectorMaximum hop count of 15 Maximum hop count of 15Classful ClasslessBroadcast based Use multicast 224.0.0.9No support for VLSM Supports VLSM networksNo authentication Allows for MD5 authentication

IGRP – Interior Gateway Routing Protocol

Page 50: CCNA 640-802

It is a Cisco proprietary distance-vector routing protocol. This means that to use IGRP in your network, all your routers must be Cisco routers. Cisco created this routing protocol to overcome the problems associated with RIP.

IGRP has maximum hop count of 255 with the default being 100.

IGRP uses different metric than RIP. IGRP uses bandwidth and delay of the line by default as a metric for determining the best route to an internetwork.

IGRP RIPCan be used in large internetwork

Uses an autonomous system number for activation

Gives a full route table update every 90 sec

Has an administrative distance of 100

Uses bandwidth and delay of the line as metric, with maximum hop count of 255

Works best in smaller networks

Does not use autonomous system number

Gives a full route table update every 30 sec

Has an administrative distance of 120

Uses only hop count to determine the best to a remote network, with 15 hops being maximum

Page 51: CCNA 640-802

Consider the above fig. The configuration is shown below

Router A

RouterA(config)#router igrp 10

RouterA(config)#network 192.168.10.0

RouterA(config)#network 192.168.20.0

Router B

RouterB(config)# router igrp 10

RouterB(config)#network 192.168.20.0

RouterB(config)#network 192.168.30.0

RouterB(config)#network 192.168.40.0

Router C

RouterC(config)# router igrp 10

RouterC(config)#network 192.168.40.0

RouterC(config)#network 192.168.50.0

*here router igrp 10 is used. 10 is an autonomous system number, which denotes the logical group no. It may be from 1 to 65565.

Verifying configuration

Router# show ip route

Router# show ip protocols

Router# debug ip rip

Troubleshooting with show ip protocols command

Router# show ip protocols

Router# show ip interface brief

Page 52: CCNA 640-802

CHAPTER 7

Enhanced IGRP (EIGRP)

And

Open Shortest Path First (OSPF)

Enhanced IGRP is a classless, enhanced distance-vector protocol that gives us a real edge over another Cisco proprietary protocol, Interior Gateway Routing Protocol.

Like IGRP, EIGRP uses the concept of an autonomous system to describe the set of contiguous routers that run the same routing protocol and share routing information. But the difference is that this includes the subnet mask in its route updates, which is not in IGRP. By including subnet mask in route updates, this allows us to use Variable Length Subnet Masks (VLSMs)

EIGRP is referred as a hybrid protocol because it has characteristics of both distance-vector and link-state protocols.

Following are the features of EIGRP:

Support for IPv4 and IPv6 Considered classless (same as RIPv2 and OSPF) Support for summaries and discontiguous networks Efficient neighbor discovery Communication via Reliable Transport Protocol (RTP) Best path selection via Diffusing Update Algorithm (DUAL)

One of the most interesting features of EIGRP is that it provides routing support for multiple Network layer protocols: IP,IPX,AppleTalk, and now IPv6. It supports different Network layer protocols through the use of protocol-dependent modules (PDMs). Each EIGRP PDM will maintain a separate series of tables containing the routing information that applies to a specific protocol. This means that there will be IPv4/EIGRP or IPv6/EIGRP

Neighbor Discovery

There are three conditions that must be met for neighborship establishment:

Hello or ACK received AS numbers match Identical metrics ( K values )

Page 53: CCNA 640-802

Link- state protocols tend to use Hello massages to establish neighborship (also called adjacencies) because they normally do not send out periodic route updates and there has to be some mechanism to help neighbors realize when a new peer has moved in or an old one has left or gone down. To maintain the neighborship relationship, EIGRP routers must also continue receiving Hellos from their neighbors.

EIGRP routers that belong to different autonomous systems (ASes) don’t automatically share routing information and they don’t become neighbors. This behavior can be a real benefit when used in larger networks to reduce the amount of route information propagated through a specific AS. The only catch is that you might have to take care of redistribution between the ASes manually. When EIGRP routers receive their neighbor’s updates, they store them in a local topology table. This table contains all known routes from all known neighbors and servers as the raw material from which the best routes are selected and placed into the routing table.

Feasible distance This is the best metric along all parts to a remote network, including the metric to the neighbor that is advertising that remote network. This is the route that you will find in the routing table because it is considered the best path. The metric of a feasible distance is the metric reported by the neighbor (called reported or advertised distance) plus the metric to the neighbor reporting the route.

Reported / advertised distance This is the metric o a remote network, as reported by a neighbor. It is also routing table metric of the neighbor and is the same as the second number in parentheses as displayed in the topology table, the first number being the feasible distance.

Neighbor table Each router keeps state information about adjacent neighbors. When a newly discovered neighbor is learned, the address an interface of the neighbor are recorded, and this information is held in the neighbor table stored in RAM. There is one neighbor table for each protocol-dependent module. Sequence numbers are used to match acknowledgments with update packets. The last sequence numbers received from the neighbor is recorded so that out-of-order packets can be detected.

Topology table The topology table is populated by the protocol-dependent modules and by neighboring routers, holding each destination address and a list of neighbors that have advertised the destination. For each neighbor, the advertised metric, which comes only from the neighbor’s table, is recorded. If the neighbor is advertising this destination, it must be using the route to forward packets.

Feasible successor

Page 54: CCNA 640-802

A feasible successor is a path whose reported distance is less than the feasible distance, and it is considered a backup route. EIGRP will keep up to six feasible and placed in the routing table. The show ip eigrp topology command will display all the EIGRP feasible successor routes known to a router.Successor A successor route is the best route to a remote network. A successor route is used by EIGRP to forward traffic to a destination and is stored in the routing table. It is backed up by a feasible successor route that is stored in the topology table- if one is available.

Reliable Transport Protocol ( RTP ) EIGRP uses a proprietary protocol called Reliable Transport ( RTP ) to manage the communication of message between EIGRP- speaking routers. And as the name suggests, reliability is a key concern of this protocol. Cisco has designed a mechanism that leverages multicasts and unicasts to deliver updates quickly and to track the receipt of the data. When EIGRP sends multicast traffic, it uses the Class D address 224.0.0.10. each EIGRP router is aware of who its neighbors are, and for each multicast it sends out, it maintains a list of the neighbors who have replied. If EIGRP doesn’t get a reply a neighbor, it will switch to using unicasts to resend the same data. People often refer to this process as reliable multicast.

Diffusing Update Algorithm ( DUAL )EIGRP uses Diffusing Update Algorithm ( DUAL ) for selecting and maintaining the best path to each remote network. This algorithm allows for the following:

Backup route determination if one is available Support of VLSMs Dynamic route recoveries Queries for an alternate route if no route can be found

DUAL provides EIGRP with possibly the fastest route convergence time among all protocols. The key to EIGRP’s speedy convergence is twofold. First, EIGRP routers maintain a copy of all o their neighbor’s routes, which they use to calculate their own cost to each remote network. If the best path goes down, it may be as simple as examining the contents of the topology table to select the best replacement route. Second, if there isn’t a good alternative in the local topology table, EIGRP routers very quickly ask their neighbors for help finding one.

EIGRP Metrics

Unlike many other protocols that use a single factor to compare routers and select the best possible path, EIGRP can use a combination of four:

Bandwidth Delay Load Reliability

Page 55: CCNA 640-802

Router A

RouterA(config)#router eigrp 10

RouterA(config)#network 192.168.10.0

RouterA(config)#network 192.168.20.0

Router B

RouterB(config)# router eigrp 10

RouterB(config)#network 192.168.20.0

RouterB(config)#network 192.168.30.0

RouterB(config)#network 192.168.40.0

Page 56: CCNA 640-802

Router C

RouterC(config)# router eigrp 10

RouterC(config)#network 192.168.40.0

RouterC(config)#network 192.168.50.0

Setting Passive-Interface

Suppose, if you need to stop EIGRP from working on a specific interface, such as a BRI interface or a serial connection to the Internet. To do that, you would flag the interface as passive using the passive-interface command.

Router(config)#router eigrp 10

Router(config)#passive-interface serial 0/0

Doing this will prohibit the interface from sending or receiving Hello packets and, as a result, stop it from forming adjacencies. This means that it won’t send or receive route information on this interface.

[The impact of the passive-interface command depends upon the routing protocol under which the command is issued. For example, on an interface running RIP, the passive-interface command will prohibit the sending of route updates but allow their receipt. Thus, a RIP router with a passive interface will still learn about the networks advertised by other routers. This is different from EIGRP, where a passive-interface will neither send nor receive updates]

Verifying EIGRP

Router# show ip route (shows the entire routing table)

Router# show ip route eigrp (shows only EIGRP entries in the routing table)

Router# show ip eigrp neighbors (shows all EIGRP neighbors)

Router# show ip eigrp topology (shows entries in the EIGRP topology table)

Router# debug eigrp packet (shows Hello packets sent/received between adjacent routers)

Router# debug ip eigrp notification (shows EIGRP changes and updates as they occur on n/w)

Page 57: CCNA 640-802

OSPF – Open Shortest Path First

The Open Shortest Path First (OSPF) protocol, defined in RFC 2328 , is an Interior Gateway Protocol used to distribute routing information within a single Autonomous System. This paper examines how OSPF works and how it can be used to design and build large and complicated networks.

Background Information

OSPF protocol was developed due to a need in the internet community to introduce a high functionality non-proprietary Internal Gateway Protocol (IGP) for the TCP/IP protocol family. The discussion of the creation of a common interoperable IGP for the Internet started in 1988 and did not get formalized until 1991. At that time the OSPF Working Group requested that OSPF be considered for advancement to Draft Internet Standard.

The OSPF protocol is based on link-state technology, which is a departure from the Bellman-Ford vector based algorithms used in traditional Internet routing protocols such as RIP. OSPF has introduced new concepts such as authentication of routing updates, Variable Length Subnet Masks (VLSM), route summarization, and so forth.

These chapters discuss the OSPF terminology, algorithm and the pros and cons of the protocol in designing the large and complicated networks of today.

OSPF versus RIP

The rapid growth and expansion of today's networks has pushed RIP to its limits. RIP has certain limitations that can cause problems in large networks:

RIP has a limit of 15 hops. A RIP network that spans more than 15 hops (15 routers) is considered unreachable.

RIP cannot handle Variable Length Subnet Masks (VLSM). Given the shortage of IP addresses and the flexibility VLSM gives in the efficient assignment of IP addresses, this is considered a major flaw.

Periodic broadcasts of the full routing table consume a large amount of bandwidth. This is a major problem with large networks especially on slow links and WAN clouds.

RIP converges slower than OSPF. In large networks convergence gets to be in the order of minutes. RIP routers go through a period of a hold-down and garbage collection and slowly time-out information that has not been received recently. This is inappropriate in large environments and could cause routing inconsistencies.

RIP has no concept of network delays and link costs. Routing decisions are based on hop counts. The path with the lowest hop count to the destination is always preferred even if the longer path has a better aggregate link bandwidth and less delays.

Page 58: CCNA 640-802

RIP networks are flat networks. There is no concept of areas or boundaries. With the introduction of classless routing and the intelligent use of aggregation and summarization, RIP networks seem to have fallen behind.

Some enhancements were introduced in a new version of RIP called RIP2. RIP2 addresses the issues of VLSM, authentication, and multicast routing updates. RIP2 is not a big improvement over RIP (now called RIP 1) because it still has the limitations of hop counts and slow convergence which are essential in today’s large networks.

OSPF, on the other hand, addresses most of the issues previously presented:

With OSPF, there is no limitation on the hop count. The intelligent use of VLSM is very useful in IP address allocation.

OSPF uses IP multicast to send link-state updates. This ensures less processing on routers that are not listening to OSPF packets. Also, updates are only sent in case routing changes occur instead of periodically. This ensures a better use of bandwidth.

OSPF has better convergence than RIP. This is because routing changes are propagated instantaneously and not periodically.

OSPF allows for better load balancing.

OSPF allows for a logical definition of networks where routers can be divided into areas. This limits the explosion of link state updates over the whole network. This also provides a mechanism for aggregating routes and cutting down on the unnecessary propagation of subnet information.

OSPF allows for routing authentication by using different methods of password authentication.

OSPF allows for the transfer and tagging of external routes injected into an Autonomous System. This keeps track of external routes injected by exterior protocols such as BGP.

This of course leads to more complexity in the configuration and troubleshooting of OSPF networks. Administrators that are used to the simplicity of RIP are challenged with the amount of new information they have to learn in order to keep up with OSPF networks. Also, this introduces more overhead in memory allocation and CPU utilization. Some of the routers running RIP might have to be upgraded in order to handle the overhead caused by OSPF.

What Do We Mean by Link-States?

OSPF is a link-state protocol. We could think of a link as being an interface on the router. The state of the link is a description of that interface and of its relationship to its neighboring routers. A description of the interface would include, for example, the IP address of the interface, the mask, the type of network it is connected to, the routers connected to that network and so on. The collection of all these link-states would form a link-state database.

Shortest Path First Algorithm

Page 59: CCNA 640-802

OSPF uses a shorted path first algorithm in order to build and calculate the shortest path to all known destinations. The shortest path is calculated with the use of the Dijkstra algorithm. The algorithm by itself is quite complicated. This is a very high level, simplified way of looking at the various steps of the algorithm:

1. Upon initialization or due to any change in routing information, a router generates a link-state advertisement. This advertisement represents the collection of all link-states on that router.

2. All routers exchange link-states by means of flooding. Each router that receives a link-state update should store a copy in its link-state database and then propagate the update to other routers.

3. After the database of each router is completed, the router calculates a Shortest Path Tree to all destinations. The router uses the Dijkstra algorithm in order to calculate the shortest path tree. The destinations, the associated cost and the next hop to reach those destinations form the IP routing table.

4. In case no changes in the OSPF network occur, such as cost of a link or a network being added or deleted, OSPF should be very quiet. Any changes that occur are communicated through link-state packets, and the Dijkstra algorithm is recalculated in order to find the shortest path.

The algorithm places each router at the root of a tree and calculates the shortest path to each destination based on the cumulative cost required to reach that destination. Each router will have its own view of the topology even though all the routers will build a shortest path tree using the same link-state database. The following sections indicate what is involved in building a shortest path tree.

OSPF Cost

The cost (also called metric) of an interface in OSPF is an indication of the overhead required to send packets across a certain interface. The cost of an interface is inversely proportional to the bandwidth of that interface. A higher bandwidth indicates a lower cost. There is more overhead (higher cost) and time delays involved in crossing a 56k serial line than crossing a 10M Ethernet line. The formula used to calculate the cost is:

cost= 10000 0000/band with in bps

For example, it will cost 10 EXP8/10 EXP7 = 10 to cross a 10M Ethernet line and will cost 10 EXP8/1544000 = 64 to cross a T1 line.

By default, the cost of an interface is calculated based on the bandwidth; you can force the cost of an interface with the ip ospf cost<value> interface sub configuration mode command.

Shortest Path Tree

Assume we have the following network diagram with the indicated interface costs. In order to build the shortest path tree for RTA, we would have to make RTA the root of the tree and calculate the smallest cost for each destination.

Page 60: CCNA 640-802

The above is the view of the network as seen from RTA. Note the direction of the arrows in calculating the cost. For example, the cost of RTB's interface to network 128.213.0.0 is not relevant when calculating the cost to 192.213.11.0. RTA can reach 192.213.11.0 via RTB with a cost of 15 (10+5). RTA can also reach 222.211.10.0 via RTC with a cost of 20 (10+10) or via RTB with a cost of 20 (10+5+5). In case equal cost paths exist to the same destination, Cisco's implementation of OSPF will keep track of up to six next hops to the same destination.

After the router builds the shortest path tree, it will start building the routing table accordingly. Directly connected networks will be reached via a metric (cost) of 0 and other networks will be reached according to the cost calculated in the tree.

Areas and Border Routers

As previously mentioned, OSPF uses flooding to exchange link-state updates between routers. Any change in routing information is flooded to all routers in the network. Areas are introduced to put a boundary on the explosion of link-state updates. Flooding and calculation of the Dijkstra algorithm on a router is limited to changes within an area. All routers within an area have the exact link-state database. Routers that belong to multiple areas, and connect these areas to the

Page 61: CCNA 640-802

backbone area are called area border routers (ABR). ABRs must therefore maintain information describing the backbone areas and other attached areas.

An area is interface specific. A router that has all of its interfaces within the same area is called an internal router (IR). A router that has interfaces in multiple areas is called an area border router (ABR). Routers that act as gateways (redistribution)between OSPF and other routing protocols (IGRP, EIGRP, IS-IS, RIP, BGP, Static) or other instances of the OSPF routing process are called autonomous system boundary router (ASBR). Any router can be an ABR or an ASBR.

Page 62: CCNA 640-802

Configuration on Router A

Configuration on Router B

Configuration on Router C

In the above configuration, you can see, first router ospf 10 is assigned. 10 is the Process ID number. It can be the same on every router on the network, or it can be different-doesn’t matter. It’s locally significant and just enables the OSPF routing on the router.

Another thing you can see is, instead of subnet mask a wildcard mask 0.0.0.255 is used here. Wildcard mask can be obtained by subtracting the subnet from 255.255.255.255.

A 0 octet in the wildcard mask indicates that the corresponding octet in the network must match exactly. On the other hand, a 255 indicates that you don’t care what the corresponding cotet is in the network number. A network and wildcard mask combination of 1.1.1.1 0.0.0.0 would match 1.1.1.1 only and nothing else. This is really useful if you want to activate OSPF on a specific interface in a very clear and simple way. If you insist on matching a range of networks, the network and wildcard mask combination of 1.1.0.0 0.0.255.255 would match anything in the range 1.1.0.0 – 1.1.255.255.

Last thing, you can see area 0 with each network. As you must know OSPF deals with the separate areas, and the CCNA concerns with single area only.

Page 63: CCNA 640-802

OSPF Terminology

To understand the OSPF concepts in a better way, it is very important to know the terms used in OSPF. The following list display the descriptions of the various terms used.

Link - A router that is connected to the network and uses OSPF as its routing protocol is defined as a link. Every link has a state as well as IP address.

Router ID – The IP address that identifies the router is called the Router ID (RID). Neighbors – When two or more routers are connected physically with the help of an

interface such as a serial or fast Ethernet are termed as neighbors. Adjacency – Some routers use OSPF as the routing protocol and are capable of

sharing the route updates. This relationship is termed as adjacency. Hello Protocol – The protocols that are sent by the routers to discover and preserves

the relationship with the neighbors are called as hello protocols. The protocols along with the Link State Advertisements (LSAs) update the topological database.

Neighbor ship database – The list of OSPF routers for which the hello packets are acknowledge are stored in the neighbor ship database. In addition, it even stores the RID and state of the links.

Designated Router (DR) – Designated routers are decided by the Hello protocols when two or more OSPF routers attempt to access the same multi-access networks. These networks have more than one recipient. DR reduces the number of adjacencies in the multi-access network. This helps to reduce the routing protocol traffic and the topological database size.

Backup Designated router (BDR) – The router used as an alternative for the DR is termed as a backup designated router.

Broadcast (multi-access) – The networks that permit various devices to access the same network and possess the ability to transmit the packets to multiple recipients are termed as broadcast (multi-access).

Non-Broadcast multi-access (NBMA) – The networks that allow multiple devices to access the same network, but cannot broadcast the packets to multiple nodes are called as non-broadcast multi- access.

Point-to-point – When two routers are connected directly using a serial cable and the packets are transmitted using a single communication path, this type of network is termed as point-to-point connection. This eliminates the need of DRs and BDRs.

Point-to-multipoint – when a router is connected to multiple routers using a single interface, the connection is termed as point-to-multipoint connection. This again eliminates the need of Drs and BDRs.

Page 64: CCNA 640-802

OSPF and Loopback Interfaces

Loopback interfaces can be defined as the virtual software interfaces that are always active. These are not directly connected to the routers. Configuring a loopback interface with the OSPF configuration ensures that there is always an interface, which is active. If the loopback interface is not configured with OSPF, the highest IP address on the router becomes the RID. The router RID is used to broadcast the routers to the networks connected to the router and to construct Designated Routes (DR) and Backup Designated Routes (BDR).

Page 65: CCNA 640-802

Chapter 8 – Layer 2 Switching and Spanning Tree Protocol (STP)

Switching Services: Layer 2 switches and bridges are faster than routers because they don’t take up time looking at the Network layer information. Instead, they look at the frame’s hardware addresses before deciding to either forward, flood or drop the frame.

Layer 2 switching provides the following:

Hardware-based bridging (ASIC) Wire speed Low latency Low cost

Bridging Vs. LAN Switching

Bridges are software based, while switches are hardware based because they use ASIC chips to help make filtering decisions.

A switch can be viewed as a multiport bridge. Switches have a higher number of ports than most bridges.

Three Switch Functions at Layer 2

Address learning Layer 2 switches and bridges remember the source hardware address of each frame received on an interface, and they enter this information into a MAC database called a forward/filter table.

Forward/filter decisions when a frame is received on an interface, the switch looks at the destination hardware address and finds the exit interface in the MAC database. The frame is only forwarded out the specified destination port.

Loop avoidance If multiple connections between switches are created for redundancy purposes, network loops can occur, Spanning Tree Protocol (STP ) is used to stop network loops while still permitting redundancy.

Switch#show mac address-table

Vlan Mac Address Type Ports

1 0005.dccb.d74b DYNAMIC Fa0/1

1 000a.f467.9e80 DYNAMIC Fa0/3

1 000a.f467.9e8b DYNAMIC Fa0/4

1 000a.f467.9e8c DYNAMIC Fa0/3

1 0010.7b7f.c2b0 DYNAMIC Fa0/3

Page 66: CCNA 640-802

1 0030.80dc.460b DYNAMIC Fa0/3

1 0030.9492.a5dd DYNAMIC Fa0/1

1 00d0.58ad.05f4 DYNAMIC Fa0/1

Port Security

How do you stop someone from simply plugging a host into one of your switch ports or worse, adding a hub, switch, or access point into the Ethernet jack in their office? By default, MAC addresses will just dynamically appear in your MAC forward/filter database. You can stop them in their tracks by using port security.

Switch#config t

Switch (config) #int f0/1

Switch (config-if) #switchpport port-security?

aging Port-security aging commands

Mac-address Secure Mac address

maximum Max secure addresses

violation Security violation mode

Switch#config t

Switch (config) #int f0/1Switch( config-if)#switchport port-security maximum 1Switch ( config-if )#switchport port-security violation shutdown

Spanning Tree Protocol (STP)The main task of STP is to stop the network loop, which occurs for an-indefinite period on the layer 2 network. To prevent this loop, the STP monitors all the links using the spanning Tree Algorithm (STA) and blocks ports from forwarding frames. switches operate in two modes, forwarding and blocking modes. Forwarding mode means that a port can send and receive frames whereas, blocking mode means that it cannot forward or receive frames. With the help of STP, frames do not loop which makes the network path usable.

Page 67: CCNA 640-802

The user Lloyd sends a message to the user Steve using MAC address. However, Steve’s machine is in off state due to which the switches are not aware of Steve’s MAC address. According to the topology, the message passes from switch 2 to switch 1, from switch 1 to switch 3 and so on. This creates an infinite loop and the message never reaches Steve. Therefore, to avoid such loops, a port on a particular switch is put to blocking mode. This port is determined by STP.

Spanning-Tree Port StatesThe ports on a bridge or switch running STP can move through five different states:

Blocking – The port that is in the blocked mode will not forward frames. This port only listens to BPDUs. This port prevents the use of looped path.

Listening – The port listens to BPDUs and confirms that there are no loops in the network. This state is a temporary state between blocking and forwarding.

Learning – The switch port listens to BPDUs and learns the paths in the network. In this state, the port only updates the MAC address table. However, the port does not forward the frame.

Forwarding - The port sends and receives all the frames on the port. Disabled – A port in the disabled state is almost not operational and does not forwards

any frames. In addition, it is not active even in the spanning tree operation.

Catalyst 1900 Switches

The 1900 switch supports an optional external redundant power supply (RPS) and has

the capacity to support 1024 MAC address

Page 68: CCNA 640-802

Catalyst 2900 Switches

The 2900 switch provide Ethernet channel capabilities. The switches come with four and eight megabytes of memory size. The 2900 series have the capacity to support 8124 MAC address.