Click here to load reader

APOSTILA EXCEL AVANÇADO.pdf

  • View
    678

  • Download
    5

Embed Size (px)

Text of APOSTILA EXCEL AVANÇADO.pdf

EXCEL AVANADO1 Primeira parte- Formatao - Uso da funo SOMA - Copiar frmulas absolutas e relativas - Funo SE (frmulas condicionais)

FormataoQuando criamos uma nova planilha a preocupao inicial deve ser sempre com as informaes digitadas deixando para depois a formatao das mesmas. O menu Formatar/Clulas serve para formatar as informaes digitadas de acordo com a nossa preferncia.

Josu Santiago [email protected]

1

Encontramos neste menu as opes Nmero, Alinhamento, Fonte, Borda, Padres e Proteo. Com a opo Nmero, define-se a forma como ser apresentado os dados digitados. Ex.: R$ 1.200,00 - 1.200,00 - 1200,00 - 1200 - 1.200 etc,

Josu Santiago [email protected]

2

Observe acima as formas de formatao para horas e datas. Alinhamento

Josu Santiago [email protected]

3

Nesta opo podemos definir como ser o alinhamento dos dados na clula. Marque o item Retorno automtico de texto para que os dados digitados sejam organizados dentro da prpria clula. Ex.: Hora Hora Total de inicial final horas

Marque a opo Reduzir para ajustar para que os dados digitados caibam na clula sem que para isso seja feito o retorno automtico do texto. Com a opo Mesclar clulas pode-se mesclar vrias clulas fazendo com que fique sendo uma clula apenas . Ex.: Controle de horas Hora Hora inicial final Note que o ttulo faz parte apenas de uma clula

Na Orientao possvel definir a orientao da informao na clula. Ex.:

n Ja

Fe

v

M

ar

1 9 9 9

Josu Santiago [email protected]

4

Nas opes Fonte, Borda e Padres define-se qual o tipo de fonte (letra), as bordas (grades) e a cor de fundo da clula. A opo Proteo trabalha em conjunto com o menu Ferramentas/Proteger/Proteger Planilha. Se as clulas estiverem marcadas como travada e oculta, elas sero protegidas e as frmulas ocultas quando selecionar o menu Ferramentas/Proteger/Proteger Planilha . Para no proteger algumas clulas basta desmarcar as opes Travada e Oculta. A opo Oculta deve ser marcada somente se voc no quiser que outras pessoas vejam suas frmulas, somente o resultado.

Josu Santiago [email protected]

5

Funo SomaEsta opo a mais bsica do Excel, pois usamos para somar valores. =SOMA(A1:A10) - soma os valores das clulas A1 at A10. =SOMA(A1:A10;B1:B10) - soma os valores das clulas A1 at A10 e B1 at B10. Para obter a soma das clulas A1 at A10 poderamos tambm usar uma forma simples como: =A1+A2+A3+A4+A5+A6+A7+A8+A9+A10 Mas se o intervalo das clulas for do A1 at A500 fica mais fcil usando =SOMA(A1:A500). As operaes matemticas usadas normalmente so as seguintes: Potenciao Multiplicao Diviso Soma Subtrao ^ * / + -

Para montar uma frmula deve-se observar a regra matemtica para as prioridades das operaes. Se na frmula no colocarmos parnteses ( ) o Excel ir aplicar a regra matemtica. Primeiro ser considerado a potenciao, depois a multiplicao, diviso, soma e subtrao. Observe no exemplo a seguir que usaremos as mesmas operaes, mas pode-se obter resultados diferentes. =2+2*5 = (2+2) * 5 - o resultado ser 12. - o resultado ser 20.

Quando usamos parnteses, este passa a ter prioridade sobre as demais operaes.

Josu Santiago [email protected]

6

Copiar frmulas absolutas e relativasQuando copiamos uma frmula =A1*B1 para as linhas abaixo o Excel entende que as frmulas devem ser relativas ou seja, mudam de acordo com as linhas. No exemplo usado =A1*B1 sendo relativas, mudam para =A2*B2, =A3*B3 e assim por diante. Mas quando um determinado endereo deve permanecer absoluto, antes de copiar deve-se usar o smbolo $ na frmula que queremos copiar. Ex.: Na frmula =A1*B1 queremos que quando copiar para as linhas abaixo o endereo B1 permanea absoluto, ou fixo. =A1*B$1 Notem que o smbolo $ est antes do nmero 1 que identifica a linha. Depois de copiado, as frmulas ficam assim: =A2*B$1 =A3*B$1 =A4*B$1 =A5*B$1 Quando copiamos uma frmula para outras colunas, a regra a mesma, ou seja devemos colocar o smbolo que deve permanecer fixa.

$ na frmula na frente da letra que identifica a coluna

Usando o exemplo =A1*A2, quando copiamos para as outras colunas, ficam assim: =B1*B2 =C1*C2 =D1*D2 Colocando o smbolo $ antes do A1, =$A1*A2, depois de copiado, fica assim: =$A1*B2 =$A1*C2 =$A1*D2 Para fixar a coluna e a linha usa-se =$A$1*A2, pois assim, quando copiamos esta frmula para baixo ou para o lado na planilha, o endereo $A$1 sempre ficar fixo.

Josu Santiago [email protected]

7

Funo SE (frmulas condicionais)Esta funo usada para testar condies como por exemplo: Pagaremos comisso de 10% a um vendedor se as vendas ultrapassarem R$10.000,00, caso contrrio pagaremos somente 5%. Na clula A1 consta o total das vendas e em A2 vamos incluir a frmula para calcular o valor da comisso. =SE(A1>10000;A1*0,10;A1*0,05) ou =SE(A1>10000;A1*10%;A1*5%) Primeiro testamos SE A1 for maior que 10000. Logo aps vem o primeiro ponto e vrgula ( ; ) onde consta a ao que deve tomar caso o teste seja verdadeiro. Aps o segundo ponto e vrgula ( ; ) deve constar a ao caso o teste seja falso. Para verdadeiro ou falso podem ser usadas frmulas, palavras e at mesmo outra condio, que chamamos de condio encadeada. =SE(A1>10000;Legal;Que pena ) Observe que as palavras devem estar entre aspas ( ). Neste exemplo deve aparecer a palavra Legal se o teste for verdadeiro, caso contrrio, se for falso deve aparecer a palavra Que pena. Observe atentamente a regra seguinte: = SE( teste ; ao para verdadeiro ; ao para falso ) Outro exemplo, se a regio das vendas for SUL a comisso ser 10%, caso contrrio ser 5%. Na clula A1 est a regio e B2 est o valor. =SE(A1=SUL;B2*0,10;B2*0,05) Usando OU e E junto com o SE Se a regio for SUL ou NORTE ou LESTE a comisso ser de 10%, caso contrrio ser de 5%. =SE ( OU(A1=SUL ; A1=NORTE ; A1=LESTE) ; B2*0,10 ; B2*0,05) Observe bem a colocao dos parnteses e o ponto e vrgula. No ponto destacado em vermelho est as vrias condies que estamos perguntando, separados por ponto e vrgula. Pode-se pr vrias opes . Para aJosu Santiago [email protected]

8

condio ser verdadeira, qualquer uma das opes serve, SUL, NORTE ou LESTE. A opo OU na frmula est isolado por parntese. OU(A1=SUL;A1=NORTE;A1=LESTE). Somente depois que vem o primeiro ponto e vrgula onde constar a opo verdadeira e logo aps, no segundo pontoe-vrgula, a opo falsa.

Exemplo para o E junto com o SE.

Se o total das vendas for entre R$10.000,00 e R$20.000,00, a comisso ser de 10%, caso contrrio ser de 5%. = SE ( E (A1>=10000 ; A1